summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@posteo.net>2021-09-22 21:05:22 -0500
committerEric Bavier <bavier@posteo.net>2021-09-22 21:06:33 -0500
commit55844efecc1e8b90b1259a40d7b81878570e8dbf (patch)
treef01796ed0299754fb9cf266a6e9376c58d92bbcd /gnu/packages/video.scm
parent904c3d69102d44133b4bfeeb55da09c603f78dcd (diff)
downloadguix-55844efecc1e8b90b1259a40d7b81878570e8dbf.tar.gz
gnu: handbrake: Update to 1.4.1.
* gnu/packages/video.scm (handbrake): Update to 1.4.1
[inputs]: Add libjpeg-turbo and zimg.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0fa7dd5bb5..c0be286cec 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -12,7 +12,7 @@
 ;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
 ;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2016, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2016, 2018, 2019, 2020, 2021 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2017 Feng Shu <tumashu@163.com>
 ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -3652,7 +3652,7 @@ supported players in addition to this package.")
 (define-public handbrake
   (package
     (name "handbrake")
-    (version "1.3.3")
+    (version "1.4.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/HandBrake/HandBrake/"
@@ -3660,7 +3660,7 @@ supported players in addition to this package.")
                                   "HandBrake-" version "-source.tar.bz2"))
               (sha256
                (base32
-                "11bzhyp052bmng5119x74xvdj5632smx6qsk537ygda8bzckg2i1"))
+                "1xhq9jjmf854jf7sg4m754hgajnavwwhmjnaikcf2vgjr35ax81r"))
               (modules '((guix build utils)))
               (snippet
                ;; Remove "contrib" and source not necessary for
@@ -3701,6 +3701,7 @@ supported players in addition to this package.")
        ("libdvdnav" ,libdvdnav)
        ("libdvdread" ,libdvdread)
        ("libgudev" ,libgudev)
+       ("libjpeg-turbo" ,libjpeg-turbo)
        ("libmpeg2" ,libmpeg2)
        ("libnotify" ,libnotify)
        ("libnuma" ,numactl)
@@ -3714,6 +3715,7 @@ supported players in addition to this package.")
        ("libx264" ,libx264)
        ("speex" ,speex)
        ("x265" ,x265)
+       ("zimg" ,zimg)
        ("zlib" ,zlib)))
     (arguments
      `(#:tests? #f             ;tests require Ruby and claim to be unsupported