summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAntoine Côté <antoine.cote@posteo.net>2023-11-20 14:51:53 +0000
committerLudovic Courtès <ludo@gnu.org>2024-01-07 16:56:00 +0100
commit5d97fdb608a89e8653f093bf34720e0822124805 (patch)
tree2262b0ee1a8ad8a6ea197e938cb97331a42db26a /gnu/packages/video.scm
parentce4fbea7bb3ec43a220ee3654c19fc52c00cc9d5 (diff)
downloadguix-5d97fdb608a89e8653f093bf34720e0822124805.tar.gz
gnu: mkvtoolnix: Update to 80.0.
* gnu/packages/video.scm (mkvtoolnix): Update to 80.0.
[inputs]: Add GMP and QTSVG.  Replace QT*-5 by their non-suffixed
variant.
[native-inputs]: Likewise, and change to RUBY-3.2.

Change-Id: If01ce578c9f9ac50e1c99e96c110687e8872177c
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f7d720f89d..d1b163dc8b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1047,14 +1047,14 @@ H.264 (MPEG-4 AVC) video streams.")
 (define-public mkvtoolnix
   (package
     (name "mkvtoolnix")
-    (version "52.0.0")
+    (version "80.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://mkvtoolnix.download/sources/"
                            "mkvtoolnix-" version ".tar.xz"))
        (sha256
-        (base32 "15y7ahlifsclnkl70wn5w34dil8nwcwcjnw3k2ydqc6dz4vb0j5s"))
+        (base32 "1x9k9pmw7mzm2amvm251a45dlj9p9iqfank5p4w2fizxkapws25v"))
        (modules '((guix build utils)))
        (snippet '(begin
                    ;; Delete bundled libraries.
@@ -1070,6 +1070,7 @@ H.264 (MPEG-4 AVC) video streams.")
     (outputs '("out" "gui")) ; "mkvtoolnix-gui" brings the closure size from ~300 MB to 1.5+ GB.
     (inputs
      (list boost
+           gmp
            bzip2
            cmark
            libebml
@@ -1083,8 +1084,9 @@ H.264 (MPEG-4 AVC) video streams.")
            lzo
            pcre2
            pugixml
-           qtbase-5
-           qtmultimedia-5
+           qtbase
+           qtmultimedia
+           qtsvg
            utfcpp
            zlib))
     (native-inputs
@@ -1096,8 +1098,8 @@ H.264 (MPEG-4 AVC) video streams.")
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("po4a" ,po4a)
-       ("qttools-5" ,qttools-5)
-       ("ruby" ,ruby-2.7)))
+       ("qttools" ,qttools)
+       ("ruby" ,ruby-3.2)))
     (arguments
      `(#:configure-flags
        (list (string-append "--with-boost="