summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-03-02 21:22:59 +0800
committerLudovic Courtès <ludo@gnu.org>2018-03-07 11:22:42 +0100
commit63d99002961c8845cd16ae4b5e9ae6b273d43a80 (patch)
treeda0b035ad761eda66c3197b5b7dcf743e4ff69b3 /gnu/packages/video.scm
parent270750d440b4b2c5f88694b5abc2c2b48046d173 (diff)
downloadguix-63d99002961c8845cd16ae4b5e9ae6b273d43a80.tar.gz
gnu: youtube-viewer: Add '$out/lib/perl5/site_perl/' to search path.
Fixes <https://bugs.gnu.org/30671>.
Reported by Ricardo Wurmus <rekado@elephly.net>.

* gnu/packages/video.scm (youtube-viewer)[arguments]: In 'wrap-program'
phase, add '$out/lib/perl5/site_perl/' to search path.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e4e71e9dcc..7d072009a0 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1344,16 +1344,18 @@ audio, images) from the Web.  It can use either mpv or vlc for playback.")
                   (guix build utils)
                   (srfi srfi-26))
        #:module-build-flags '("--gtk")
-       #:phases (modify-phases %standard-phases
-                  (add-after 'install 'wrap-program
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let ((bin-dir (string-append (assoc-ref outputs "out")
-                                                    "/bin/"))
-                            (perl-path (getenv "PERL5LIB")))
-                        (for-each (cut wrap-program <>
-                                       `("PERL5LIB" ":" prefix (,perl-path)))
-                                  (find-files bin-dir))
-                        #t))))))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-program
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin-dir (string-append out "/bin/"))
+                    (site-dir (string-append out "/lib/perl5/site_perl/"))
+                    (lib-path (getenv "PERL5LIB")))
+               (for-each (cut wrap-program <>
+                              `("PERL5LIB" ":" prefix (,lib-path ,site-dir)))
+                         (find-files bin-dir))
+               #t))))))
     (synopsis
      "Lightweight application for searching and streaming videos from YouTube")
     (description