summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-07-18 12:50:42 -0300
committerVinicius Monego <monego@posteo.net>2022-08-13 02:34:03 -0300
commitc7f3cdb78e800f17d9bb04cc01b3e62202ca6720 (patch)
tree5db5d9fbe42c737a0a1849efde9702194114ffe0 /gnu/packages/video.scm
parentab959f8a117b7d041e6c89fa2ab989412c4aef74 (diff)
downloadguix-c7f3cdb78e800f17d9bb04cc01b3e62202ca6720.tar.gz
gnu: shotcut: Update to 22.06.23.
* gnu/packages/video.scm (shotcut): Update to 22.06.23.
[arguments]: Do not replace the 'configure phase as Shotcut switched to the
CMake build system in this version.
[inputs]: Add fftw.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index dcd58d5e02..68f129dee7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4804,7 +4804,7 @@ transitions, and effects and then export your film to many common formats.")
 (define-public shotcut
   (package
     (name "shotcut")
-    (version "22.04.25")
+    (version "22.06.23")
     (source
      (origin
        (method git-fetch)
@@ -4813,7 +4813,7 @@ transitions, and effects and then export your film to many common formats.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0ccbx2crqrnhl19d7267xc40vs0cjmps2cnhi1g1l6bqxbi7k88x"))))
+        (base32 "1kvhcblzjdjiv3jggdx41djq9pz6a9hg4ilgcwin13gb19ir7dcc"))))
     (build-system qt-build-system)
     (arguments
      `(#:tests? #f                      ;there are no tests
@@ -4830,14 +4830,6 @@ transitions, and effects and then export your film to many common formats.")
                (substitute* "src/jobs/meltjob.cpp"
                  (("\"melt\"") (string-append "\"" mlt "/bin/melt\""))
                  (("\"melt-7\"") (string-append "\"" mlt "/bin/melt-7\""))))))
-         (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out")))
-               (invoke "qmake"
-                       (string-append "PREFIX=" out)
-                       "QMAKE_LRELEASE=lrelease"
-                       "QMAKE_LUPDATE=lupdate"
-                       "shotcut.pro"))))
          (add-after 'install 'wrap-executable
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -4862,6 +4854,7 @@ transitions, and effects and then export your film to many common formats.")
     (inputs
      (list bash-minimal
            ffmpeg
+           fftw
            frei0r-plugins
            jack-1
            ladspa