summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-01-25 02:06:32 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-01-31 06:35:01 +0300
commitd84e22578abb75aa5752ed0b41864faab23d338e (patch)
tree8119d6bb00be4e6422da37a682a955b12e2c7adc /gnu/packages/video.scm
parent3001234da211269cef9fec0a34f8b6176cb2f2bf (diff)
downloadguix-d84e22578abb75aa5752ed0b41864faab23d338e.tar.gz
gnu: livestreamer: Deprecate in favour of streamlink.
* gnu/packages/video.scm (livestreamer): Redefine using ‘deprecated-package’.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm27
1 files changed, 3 insertions, 24 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cb46e4315a..4ffc15e303 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1714,30 +1714,6 @@ pixel motion compensation, lumi masking, trellis quantization, and H.263, MPEG
 and custom quantization matrices.")
     (license license:gpl2+)))
 
-(define-public livestreamer
-  (package
-    (name "livestreamer")
-    (version "1.12.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/chrippa/livestreamer/archive/v"
-                    version ".tar.gz"))
-              (file-name (string-append "livestreamer-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1fp3d3z2grb1ls97smjkraazpxnvajda2d1g1378s6gzmda2jvjd"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:tests? #f)) ; tests rely on external web servers
-    (propagated-inputs
-     `(("python-requests" ,python-requests)))
-    (synopsis "Internet video stream viewer")
-    (description "Livestreamer is a command-line utility that extracts streams
-from various services and pipes them into a video playing application.")
-    (home-page "http://livestreamer.io/")
-    (license license:bsd-2)))
-
 (define-public streamlink
   (package
     (name "streamlink")
@@ -1767,6 +1743,9 @@ from various services and pipes them into a video playing application.")
 from sites like Twitch.tv and pipes them into a video player of choice.")
     (license license:bsd-2)))
 
+(define-public livestreamer
+  (deprecated-package "livestreamer" streamlink))
+
 (define-public mlt
   (package
     (name "mlt")