summary refs log tree commit diff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-24 23:38:07 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:37 -0400
commitf3b5201c86ea1b71ef4420c8ab4be7aedf1de6a5 (patch)
treeea1b93c7c71e174a839d16223b961ee9fbe9a201 /gnu/packages/video.scm
parentde97f3fad9d8942cca3131b02f323da01378e7c9 (diff)
downloadguix-f3b5201c86ea1b71ef4420c8ab4be7aedf1de6a5.tar.gz
gnu: ffmpeg-5: Rename variable to ffmpeg.
* gnu/packages/video.scm (ffmpeg-5): Rename to...
(ffmpeg): ... this, replacing the old 'ffmpeg' alias.
(ffmpeg-4): Adjust accordingly.
* gnu/packages/jami.scm (ffmpeg-jami): Likewise.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 8ecbaa2602..bf9a7c8d03 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1576,7 +1576,7 @@ These tools require a supported graphics chip, driver, and VA-API back end to
 operate properly.")
     (license license:expat)))
 
-(define-public ffmpeg-5
+(define-public ffmpeg
   (package
     (name "ffmpeg")
     (version "5.1.2")
@@ -1772,7 +1772,7 @@ audio/video codec library.")
 
 (define-public ffmpeg-4
   (package
-    (inherit ffmpeg-5)
+    (inherit ffmpeg)
     (version "4.4.2")
     (source (origin
              (method url-fetch)
@@ -1781,10 +1781,10 @@ audio/video codec library.")
              (sha256
               (base32
                "14xadxm1yaamp216nq09xwasxg5g133v86dbb33mdg5di1zrlhdg"))))
-    (inputs (modify-inputs (package-inputs ffmpeg-5)
+    (inputs (modify-inputs (package-inputs ffmpeg)
               (replace "sdl2" sdl2-2.0)))
     (arguments
-     (substitute-keyword-arguments (package-arguments ffmpeg-5)
+     (substitute-keyword-arguments (package-arguments ffmpeg)
        ((#:configure-flags flags ''())
         #~(cons "--enable-avresample" #$flags))))))
 
@@ -1863,8 +1863,6 @@ audio/video codec library.")
     (inputs (modify-inputs (package-inputs ffmpeg-3.4)
               (delete "libwebp")))))
 
-(define-public ffmpeg ffmpeg-5)
-
 (define-public ffmpeg-for-stepmania
   (hidden-package
    (package