summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-27 19:07:10 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-28 09:35:07 +0200
commita947ade67d02a3fcb4bfe4f0dcb1d4c575cd6368 (patch)
tree5af2902c5c505ea919aaf9566ba32a2742a67ab4 /gnu/packages/vim.scm
parent7ee8acbb76bd440a8985a4b2a20b75521c6853ed (diff)
downloadguix-a947ade67d02a3fcb4bfe4f0dcb1d4c575cd6368.tar.gz
gnu: Add vim-guix-vim.
* gnu/packages/vim.scm (vim-guix-vim): New variable.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index b5952e3e21..f130ae4392 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -938,3 +938,37 @@ through its msgpack-rpc API.")
 
 (define-public python2-pynvim
   (package-with-python2 python-pynvim))
+
+(define-public vim-guix-vim
+  (package
+    (name "vim-guix-vim")
+    (version "0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://gitlab.com/Efraim/guix.vim")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1f8h8m96fqh3f9hy87spgh9kdqzyxl11n9s3rywvyq5xhn489bnk"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'build)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (vimfiles (string-append out "/share/vim/vimfiles")))
+               (for-each
+                 (lambda (dir)
+                   (copy-recursively dir (string-append vimfiles "/" dir)))
+                 '("compiler" "doc" "indent" "ftdetect" "ftplugin" "syntax"))
+               #t))))))
+    (home-page "https://gitlab.com/Efraim/guix.vim")
+    (synopsis "Guix integration in Vim")
+    (description "This package provides support for GNU Guix in Vim.")
+    (license license:vim)))