summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-23 17:15:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-23 17:55:05 +0100
commitb947ba77e60d3d3c5cc6a1c914096e7dab1f7db7 (patch)
treece041736df4cc93151932e398f3b5cb0cb1ead5d /gnu/packages/vim.scm
parentc917c23e7295370e42c4aff40219a60066607378 (diff)
downloadguix-b947ba77e60d3d3c5cc6a1c914096e7dab1f7db7.tar.gz
gnu: vim: Fix build on CoW file systems.
* gnu/packages/vim.scm (vim)[arguments]: Add disable-CoW phase.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 67f245b26d..579b21524e 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -84,6 +84,12 @@
        #:parallel-tests? #f
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'disable-CoW
+           ;; Disable copy-on-write (CoW) in the build directory.  Tests fail on
+           ;; btrfs (and possibly other CoW file systems) for unclear reasons.
+           ;; This needs to be run early as it only affects newly-created files.
+           (lambda _
+             (invoke "chattr" "-R" "+C" ".")))
          (add-after 'configure 'patch-config-files
            (lambda _
              (substitute* "runtime/tools/mve.awk"
@@ -128,6 +134,7 @@
      `(("libtool" ,libtool)
 
        ;; For tests.
+       ("e2fsprogs" ,e2fsprogs)         ; for chattr in disable-CoW above
        ("tzdata" ,tzdata-for-tests)))
     (home-page "https://www.vim.org/")
     (synopsis "Text editor based on vi")