summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-02 09:56:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-02 09:56:11 +0300
commitf7a8571b378c1fbb509681afd5dc5dc8315e11b4 (patch)
tree72e7cb70e1a79c36a1e83b737e343ec37c3bc1b0 /gnu/packages/vim.scm
parent9460884422466fc63e98d8dea6eccd8176187999 (diff)
downloadguix-f7a8571b378c1fbb509681afd5dc5dc8315e11b4.tar.gz
gnu: vim-fugitive: Update to 3.0.
* gnu/packages/vim.scm (vim-fugitive): Update to 3.0.
[arguments]: Install syntax directory.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 1eede0b22a..8ebdbb9a35 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -483,7 +483,7 @@ trouble using them, because you do not have to remember each snippet name.")
 (define-public vim-fugitive
   (package
     (name "vim-fugitive")
-    (version "2.5")
+    (version "3.0")
     (source
       (origin
         (method git-fetch)
@@ -493,7 +493,7 @@ trouble using them, because you do not have to remember each snippet name.")
         (file-name (git-file-name name version))
         (sha256
          (base32
-          "17yz7gxn7a49jzndr4z5vnk1y4a6c22qss3mwxzmq4m46fni0k8q"))))
+          "0ghh8a9xysc3njqql1khhl2dkhymz93snpwqp2apm7pka6l893bc"))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f
@@ -506,13 +506,15 @@ trouble using them, because you do not have to remember each snippet name.")
              (let* ((out (assoc-ref outputs "out"))
                     (vimfiles (string-append out "/share/vim/vimfiles"))
                     (autoload (string-append vimfiles "/autoload"))
-                    (doc (string-append vimfiles "/doc"))
+                    (doc      (string-append vimfiles "/doc"))
                     (ftdetect (string-append vimfiles "/ftdetect"))
-                    (plugin (string-append vimfiles "/plugin")))
+                    (plugin   (string-append vimfiles "/plugin"))
+                    (syntax   (string-append vimfiles "/syntax")))
                (copy-recursively "autoload" autoload)
                (copy-recursively "doc" doc)
                (copy-recursively "ftdetect" ftdetect)
                (copy-recursively "plugin" plugin)
+               (copy-recursively "syntax" syntax)
                #t))))))
     (home-page "https://github.com/tpope/vim-fugitive")
     (synopsis "Vim plugin to work with Git")