summary refs log tree commit diff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorBenjamin <benjamin@uvy.fr>2023-05-02 10:54:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 12:22:20 +0300
commitfccb48d2cec6bcf47647c82914f31e2dff617f9c (patch)
tree22cb1685bcd7ab6d5d4b92904fc7828d36157914 /gnu/packages/vim.scm
parent23bc492dcaf8b63d209d0478fe4a3ed37fab57b9 (diff)
downloadguix-fccb48d2cec6bcf47647c82914f31e2dff617f9c.tar.gz
gnu: neovim update to 0.9.0.
* gnu/packages/vim.scm (neovim): Update to 0.9.0.
[arguments]: Adjust phase 'prevent-embedding-gcc-store-path to changes
in the source code.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 53a8a082eb..df077f9795 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -693,7 +693,7 @@ are detected, the user is notified.")))
 (define-public neovim
   (package
     (name "neovim")
-    (version "0.8.3")
+    (version "0.9.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -702,7 +702,7 @@ are detected, the user is notified.")))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1zff73yxbnxym6sn43xk6r0zc2ncingsib81v9g39ibrcinpwaa9"))))
+                "0xsvhm191cy5ivcw0c8dnpzbpcvvn5hsnkzkipr2aabgrsgqj628"))))
     (build-system cmake-build-system)
     (arguments
      (list #:modules
@@ -751,8 +751,8 @@ are detected, the user is notified.")))
                  (lambda _
                    ;; nvim remembers its build options, including the compiler with
                    ;; its complete path.  This adds gcc to the closure of nvim, which
-                   ;; doubles its size.  We remove the refirence here.
-                   (substitute* "cmake/GetCompileFlags.cmake"
+                   ;; doubles its size.  We remove the reference here.
+                   (substitute* "cmake.config/versiondef.h.in"
                      (("\\$\\{CMAKE_C_COMPILER\\}") "/gnu/store/.../bin/gcc"))
                    #t)))))
     (inputs (list libuv-for-luv