summary refs log tree commit diff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2018-04-21 10:37:20 +0100
committerLudovic Courtès <ludo@gnu.org>2018-04-22 23:50:49 +0200
commit01224157b7714ff5a7931475943f9479d09c62a3 (patch)
tree2ebb2b4db872b4ef7fb86933df35da79d5fffdfc /gnu/packages/vpn.scm
parentc51e592d6c5d68ba6e21c925cfed9ed1fe06ef3d (diff)
downloadguix-01224157b7714ff5a7931475943f9479d09c62a3.tar.gz
gnu: Add ocproxy.
* gnu/packages/vpn.scm (ocproxy): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 070b695651..6ba3677a90 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,9 +33,11 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages libevent)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -206,6 +209,39 @@ example for writing your own.  For example, @command{vpnc-script-sshd} contains
 the entire VPN in a network namespace accessible only through SSH.")
       (license license:gpl2+))))
 
+(define-public ocproxy
+  (package
+    (name "ocproxy")
+    (version "1.60")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/cernekee/ocproxy/archive/v"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1b4rg3xq5jnrp2l14sw0msan8kqhdxmsd7gpw9lkiwvxy13pcdm7"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)))
+    (inputs
+     `(("libevent" ,libevent)))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'autogen
+           (lambda _ (invoke "sh" "autogen.sh"))))))
+    (home-page "https://github.com/cernekee/ocproxy")
+    (synopsis "OpenConnect proxy")
+    (description
+     "User-level @dfn{SOCKS} and port forwarding proxy for OpenConnect based
+on LwIP.  When using ocproxy, OpenConnect only handles network activity that
+the user specifically asks to proxy, so the @dfn{VPN} interface no longer
+\"hijacks\" all network traffic on the host.")
+    (license license:bsd-3)))
+
 (define-public openconnect
   (package
    (name "openconnect")