summary refs log tree commit diff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-23 19:11:04 -0500
committerjgart <jgart@dismail.de>2024-07-24 21:46:06 -0500
commit54fe562019d26d09acd3e29e09a718d451074c9d (patch)
tree101bc177652d22ec1b3b34ed3bc0f9f33ab4eccf /gnu/packages/vpn.scm
parent103595d86844c419840a4d68c9d0b6b82224f331 (diff)
downloadguix-54fe562019d26d09acd3e29e09a718d451074c9d.tar.gz
gnu: sshuttle: Improve package style.
* gnu/packages/vpn.scm (sshuttle) [arguments]: Use G-expressions.

Change-Id: Ia8961e3382116d0f1e67a7feb181f1e0fd6a5caf
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 956a769199..199f523461 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -995,15 +995,14 @@ private network between hosts on the internet.")
         (base32 "01hd7z7gxkc2bjxndnv5dw1x98qcakxli9k8w285iq2b7d786f7f"))))
     (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-FHS-file-names
-           (lambda _
-             (substitute* "sshuttle/client.py"
-               (("/usr/bin/env") (which "env")))
-             (substitute* "sshuttle/ssh.py"
-               (("/bin/sh") "sh"))
-             #t)))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-FHS-file-names
+                 (lambda _
+                   (substitute* "sshuttle/client.py"
+                     (("/usr/bin/env") (which "env")))
+                   (substitute* "sshuttle/ssh.py"
+                     (("/bin/sh") "sh")))))))
     (native-inputs
      (list python-setuptools-scm
            ;; For tests only.