summary refs log tree commit diff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 14:39:49 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-03 14:39:49 +0100
commite6c847defb6cb25c65172dec46a322e5d3d45088 (patch)
tree3d249dce1a1f58fcb3c83a41eaf9e1525d7b112e /gnu/packages/web-browsers.scm
parent3aef72ec5bf1027bc557daab7010848d80711a28 (diff)
parent179bb57d2532ee6b81791e078b0f782cbf88cb84 (diff)
downloadguix-e6c847defb6cb25c65172dec46a322e5d3d45088.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm53
1 files changed, 27 insertions, 26 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 94468b9b5d..e775118f16 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -21,6 +21,7 @@
 ;;; Copyright © 2021 Alexander Krotov <krotov@iitp.ru>
 ;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2021 Christopher Howard <christopher@librehacker.com>
+;;; Copyright © 2023 Herman Rimm <herman@rimm.ee>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -69,6 +70,7 @@
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnome-xyz)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages gstreamer)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
@@ -460,7 +462,7 @@ interface.")
 (define-public qutebrowser
   (package
     (name "qutebrowser")
-    (version "2.5.4")
+    (version "3.1.0")
     (source
      (origin
        (method url-fetch)
@@ -468,7 +470,7 @@ interface.")
                            "qutebrowser/releases/download/v" version "/"
                            "qutebrowser-" version ".tar.gz"))
        (sha256
-        (base32 "1c8skkc5vjbvbslz65hzrj9d05v4zbcjbli61ikjmr174lhb4q54"))))
+        (base32 "0prf9c7nx4aizfczjb0fpsn3alz210i6wc7s2jwb1mh8r8fcq3ah"))))
     (build-system python-build-system)
     (native-inputs
      (list python-attrs))               ; for tests
@@ -481,15 +483,13 @@ interface.")
            python-pynacl
            python-pypeg2
            python-pyyaml
-           ;; FIXME: python-pyqtwebengine needs to come before python-pyqt so
-           ;; that it's __init__.py is used first.
-           python-pyqtwebengine
-           python-pyqt
-           ;; While qtwebengine-5 is provided by python-pyqtwebengine, it's
+           python-pyqt-6
+           python-pyqtwebengine-6
+           ;; While qtwebengine is provided by python-pyqtwebengine-6, it's
            ;; included here so we can wrap QTWEBENGINEPROCESS_PATH.
-           qtwebengine-5))
+           qtwebengine))
     (arguments
-     `(;; FIXME: With the existance of qtwebengine-5, tests can now run.  But
+     `(;; FIXME: With the existence of qtwebengine, tests can now run.  But
        ;; they are still disabled because test phase hangs.  It's not readily
        ;; apparent as to why.
        #:tests? #f
@@ -539,13 +539,16 @@ interface.")
          (add-after 'wrap 'wrap-qt-process-path
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (wrap-program (search-input-file outputs "bin/qutebrowser")
+               `("QTWEBENGINE_RESOURCES_PATH" =
+                 (,(search-input-directory
+                    inputs "/share/qt6/resources")))
                `("QTWEBENGINEPROCESS_PATH" =
                  (,(search-input-file
-                    inputs "/lib/qt5/libexec/QtWebEngineProcess")))))))))
+                    inputs "/lib/qt6/libexec/QtWebEngineProcess")))))))))
     (home-page "https://qutebrowser.org/")
     (synopsis "Minimal, keyboard-focused, vim-like web browser")
     (description "qutebrowser is a keyboard-focused browser with a minimal
-GUI.  It is based on PyQt5 and QtWebEngine.")
+GUI.  It is based on PyQt6 and QtWebEngine.")
     (license license:gpl3+)))
 
 (define-public vimb
@@ -587,7 +590,7 @@ driven and does not detract you from your daily work.")
 (define-public nyxt
   (package
     (name "nyxt")
-    (version "3.11.0")
+    (version "3.11.1")
     (source
      (origin
        (method git-fetch)
@@ -596,7 +599,7 @@ driven and does not detract you from your daily work.")
              (commit version)))
        (sha256
         (base32
-         "0hzkpk8kshw7afz3pryi99xz2vg3v676day0mgji3hvaazfan39p"))
+         "107zsjpwhdiafgj55zdbqj6qwyvpfcdf8vxn16sry16r2jaxxagf"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
@@ -608,14 +611,9 @@ driven and does not detract you from your daily work.")
        (modify-phases %standard-phases
          (delete 'configure)
          (add-before 'build 'fix-common-lisp-cache-folder
-           (lambda _
-             (setenv "HOME" "/tmp")
-             #t))
+           (lambda _ (setenv "HOME" "/tmp")))
          (add-before 'check 'configure-tests
-           (lambda _
-             (setenv "NYXT_TESTS_NO_NETWORK" "1")
-             (setenv "NYXT_TESTS_ERROR_ON_FAIL" "1")
-             #t))
+           (lambda _ (setenv "NYXT_TESTS_NO_NETWORK" "1") #t))
          (add-after 'install 'wrap-program
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((bin (string-append (assoc-ref outputs "out") "/bin/nyxt"))
@@ -637,8 +635,7 @@ driven and does not detract you from your daily work.")
                    (,(string-append glib-networking "/lib/gio/modules")))
                  `("GI_TYPELIB_PATH" prefix (,gi-path))
                  `("LD_LIBRARY_PATH" ":" prefix (,path))
-                 `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))
-               #t))))))
+                 `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))))))))
     (native-inputs (list cl-lisp-unit2 sbcl))
     (inputs (list sbcl-alexandria
                   sbcl-bordeaux-threads
@@ -663,14 +660,12 @@ driven and does not detract you from your daily work.")
                   sbcl-dissect
                   sbcl-enchant
                   sbcl-flexi-streams
-                  sbcl-fset
                   sbcl-history-tree
                   sbcl-iolib
                   sbcl-lass
                   sbcl-local-time
                   sbcl-log4cl
                   sbcl-lparallel
-                  sbcl-mk-string-metrics
                   sbcl-montezuma
                   sbcl-moptilities
                   sbcl-named-readtables
@@ -708,9 +703,15 @@ driven and does not detract you from your daily work.")
                   gtk+                  ; For the main loop
                   webkitgtk-for-gtk3    ; Required when we use its typelib
                   gobject-introspection
-                  pkg-config))
+                  pkg-config
+                  ;; Useful for video playback
+                  gst-libav
+                  gst-plugins-bad
+                  gst-plugins-base
+                  gst-plugins-good
+                  gst-plugins-ugly))
     (synopsis "Extensible web-browser in Common Lisp")
-    (home-page "https://nyxt.atlas.engineer")
+    (home-page "https://nyxt-browser.com/")
     (description "Nyxt is a keyboard-oriented, extensible web-browser designed
 for power users.  The application has familiar Emacs and VI key-bindings and
 is fully configurable and extensible in Common Lisp.")