summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-11 16:25:58 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-12 15:55:56 -0500
commit0148aa55cf05bbdbd9146fea4483d06cffaae533 (patch)
tree7f66fecfa817ed4a5e6b98a699200e6ef3b1fb3a /gnu/packages/web.scm
parent19449405ac78d6c37bb5d061d0443f1a4487ea98 (diff)
downloadguix-0148aa55cf05bbdbd9146fea4483d06cffaae533.tar.gz
gnu: Add CGI-Simple.
* gnu/packages/web.scm (perl-cgi-simple): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7bf1642108..698380e337 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -523,6 +523,28 @@ from streaming URLs.  It is a command-line wrapper for the libquvi library.")
 to perl-code, for faster generation of access_log lines.")
     (license (package-license perl))))
 
+(define-public perl-cgi-simple
+  (package
+    (name "perl-cgi-simple")
+    (version "1.115")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SZ/SZABGAB/"
+                           "CGI-Simple-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1nkyb1m1g5r47xykflf68dplanih5p15njv82frbgbsms34kp1sg"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-io-stringy" ,perl-io-stringy))) ;for IO::Scalar
+    (home-page "http://search.cpan.org/dist/CGI-Simple")
+    (synopsis "CGI interface that is CGI.pm compliant")
+    (description "CGI::Simple provides a relatively lightweight drop in
+replacement for CGI.pm.  It shares an identical OO interface to CGI.pm for
+parameter parsing, file upload, cookie handling and header generation.")
+    (license (package-license perl))))
+
 (define-public perl-encode-locale
   (package
     (name "perl-encode-locale")