summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2023-02-11 22:44:27 -0500
committerLudovic Courtès <ludo@gnu.org>2023-03-04 18:46:37 +0100
commit0d6c5e0ba1bd6800712e79964f7b9f5c6043f249 (patch)
treec4e1c4f1369f7dc897b218ebb0a4e01052ba1d11 /gnu/packages/web.scm
parenta6194d1f35ec8ac9b58f4d05affa5aabf1ca7014 (diff)
downloadguix-0d6c5e0ba1bd6800712e79964f7b9f5c6043f249.tar.gz
gnu: Remove and deprecate tidy for tidy-html
* gnu/packages/web.scm (tidy): Change to deprecated alias for tidy-html
* gnu/packages/pumpio.scm (pumpa): Use tidy-html instead of tidy and correct
header name.
* gnu/packages/markup.scm (hoedown):
* gnu/packages/photo.scm (enblend-enfuse):
* gnu/packages/php.scm (php):
* gnu/packages/python-xyz.scm (python-pytidylib):
Use tidy-html instead of tidy.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm37
1 files changed, 3 insertions, 34 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 861f3e0419..cc206722a9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1718,40 +1718,6 @@ domains (UTF-8 and IDNA2008 Punycode), is thread-safe, and handles IDNA2008
 UTS#46.")
     (license license:x11)))
 
-(define-public tidy
-  (package
-    (name "tidy")
-    (version "20091223")
-    (source (origin
-              (method cvs-fetch)
-              (uri (cvs-reference
-                    (root-directory
-                     ":pserver:anonymous@tidy.cvs.sourceforge.net:/cvsroot/tidy")
-                    (module "tidy")
-                    (revision "2009-12-23")))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "14dsnmirjcrvwsffqp3as70qr6bbfaig2fv3zvs5g7005jrsbvpb"))
-              (patches (search-patches "tidy-CVE-2015-5522+5523.patch"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'bootstrap
-                    (lambda* (#:key inputs #:allow-other-keys)
-                      ;; configure.in and Makefile.am aren't in the root of the
-                      ;; source tree.
-                      (copy-recursively "build/gnuauto" ".")
-                      (setenv "AUTOMAKE" "automake --foreign")
-                      (invoke "autoreconf" "-vfi"))))))
-    (native-inputs
-     (list automake autoconf libtool))
-    (synopsis "HTML validator and tidier")
-    (description "HTML Tidy is a command-line tool and C library that can be
-used to validate and fix HTML data.")
-    (home-page "https://tidy.sourceforge.net/")
-    (license (license:x11-style "file:///include/tidy.h"))))
-
 (define-public esbuild
   (package
     (name "esbuild")
@@ -6204,6 +6170,9 @@ developers can integrate into their applications to make use of the
 functions of Tidy.")
     (license license:bsd-3)))
 
+(define-public tidy
+  (deprecated-package "tidy" tidy-html))
+
 (define-public hiawatha
   (package
     (name "hiawatha")