summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorChristopher Howard <christopher@librehacker.com>2023-07-19 13:35:39 -0800
committerLudovic Courtès <ludo@gnu.org>2023-08-07 15:56:46 +0200
commit1551f28ca72232ebe0ab5221906b67602296866c (patch)
tree508cad2e87e6009fef6fa8f7e5757cce18550e15 /gnu/packages/web.scm
parent2bb0f9bac6cc37955251d9b3dc33cfa148de6ebe (diff)
downloadguix-1551f28ca72232ebe0ab5221906b67602296866c.tar.gz
gnu: Add kineto.
* gnu/packages/web.scm (kineto): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e5fd081d27..7cc563586b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -62,6 +62,7 @@
 ;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
 ;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
+;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8564,6 +8565,34 @@ detection.  It delegates TLS support to an external daemon, for example
 @command{stunnel} on @command{inetd}.")
     (license license:bsd-2)))
 
+(define-public kineto
+  (package
+    (name "kineto")
+    (version "0.0.0-20211105093215-857f8c97ebc5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~sircmpwn/kineto")
+                    (commit (go-version->git-ref version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1r17c904i76yy5ilvhjczmhnq5g7r4nkjwmsjcfxcqzly0ia7m2k"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "git.sr.ht/~sircmpwn/kineto/"))
+    (propagated-inputs
+     (list go-git-sr-ht-sircmpwn-getopt go-git-sr-ht-adnano-go-gemini))
+    (home-page "https://git.sr.ht/~sircmpwn/kineto/")
+    (synopsis "HTTP proxy for Gemini")
+    (description
+     "This is an @acronym{HTTP} to
+@url{https://gemini.circumlunar.space/,Gemini} proxy designed to provide
+service for a single domain, i.e.  to make your Gemini site available over
+HTTP.  It can proxy to any domain in order to facilitate linking to the rest
+of Geminispace, but it defaults to a specific domain.")
+    (license license:gpl3+)))
+
 (define-public libzim
   (package
     (name "libzim")