summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-23 02:00:15 +0200
commit34e6c5d4280d67729bbd8cdae333ca5e0bd580f5 (patch)
tree0dfbe8510ed173230c3661b2edd1c3a5f3b90c31 /gnu/packages/web.scm
parent04ec2a15b9c12f82a445f615ca05cbe7bb42bcf5 (diff)
downloadguix-34e6c5d4280d67729bbd8cdae333ca5e0bd580f5.tar.gz
gnu: rapidjson: Fix powerpc64le-linux build.
…by avoiding ‘-march=native’, which is an unnecessary risk even if the
result is not installed.

* gnu/packages/web.scm (rapidjson)[arguments]: Replace the outdated
'patch-aarch-march-detection phase with an unconditional
'fix-march=native one.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index abdd8cacdb..d30a2145df 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1381,15 +1381,12 @@ current version of any major web browser.")
                   (delete-file-recursively "bin/jsonchecker")))))
     (build-system cmake-build-system)
     (arguments
-     (if (string-prefix? "aarch64" (or (%current-target-system)
-                                       (%current-system)))
-         '(#:phases
-           (modify-phases %standard-phases
-             (add-after 'unpack 'patch-aarch-march-detection
-               (lambda _
-                 (substitute* (find-files "." "^CMakeLists\\.txt$")
-                   (("native") "armv8-a"))))))
-         '()))
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-march=native
+           (lambda _
+             (substitute* "CMakeLists.txt"
+               (("-m[^-]*=native") "")))))))
     (home-page "https://github.com/Tencent/rapidjson")
     (synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
     (description