summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-08 17:12:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-08 17:12:44 +0200
commit3eb34c66b42d1fa520a374e9b35a6ce7bd1e8987 (patch)
tree6aae789b3edb790b19cf4a65decd82feabaf8b2e /gnu/packages/web.scm
parente9acbe6d81d94d027331d457fc12ceb9b1b2a39e (diff)
downloadguix-3eb34c66b42d1fa520a374e9b35a6ce7bd1e8987.tar.gz
gnu: nghttp2: Update to 1.41.0 and remove replacement.
* gnu/packages/web.scm (nghttp2): Update to 1.41.0.
[replacement]: Remove.
(nghttp2-1.41): Remove.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 163bfa22dc..17798c6c1d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7435,8 +7435,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
 (define-public nghttp2
   (package
     (name "nghttp2")
-    (version "1.40.0")
-    (replacement nghttp2-1.41)
+    (version "1.41.0")
     (source
      (origin
        (method url-fetch)
@@ -7445,7 +7444,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
                            "nghttp2-" version ".tar.xz"))
        (sha256
         (base32
-         "0wwhwv7cvi1vxpdjwvg0kpa4jzhszclpnwrwfcw728zz53a47z09"))))
+         "1hk77vngjmvvzb5y1gi1aqwf6qywrc7yak08zvzb7x81qs6mphmb"))))
     (build-system gnu-build-system)
     (outputs (list "out"
                    "lib"))              ; only libnghttp2
@@ -7519,20 +7518,6 @@ compressed JSON header blocks.
 @end itemize\n")
     (license license:expat)))
 
-(define-public nghttp2-1.41                       ;fixes CVE-2020-11080
-  (package
-    (inherit nghttp2)
-    (version "1.41.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/nghttp2/nghttp2/"
-                           "releases/download/v" version "/"
-                           "nghttp2-" version ".tar.xz"))
-       (sha256
-        (base32
-         "1hk77vngjmvvzb5y1gi1aqwf6qywrc7yak08zvzb7x81qs6mphmb"))))))
-
 (define-public hpcguix-web
   (let ((commit "9de63562b06b4aef3a3afe5ecb18d3c91e57ee74")
         (revision "5"))