summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-06-15 19:05:26 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-06-17 15:49:33 +0200
commit40b784b4c7c1750b17f4c5a801f784e4d69b1647 (patch)
tree8149bb6addeec7237ef3b378225f4a04d8750e93 /gnu/packages/web.scm
parent4b926cb6c88f8ecc10e927b0c33e6fc0e1d24d77 (diff)
downloadguix-40b784b4c7c1750b17f4c5a801f784e4d69b1647.tar.gz
gnu: Add python2-httpretty.
* gnu/packages/web.scm (python2-httpretty): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5f27ef957d..17583b3c80 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4614,3 +4614,52 @@ allocations, it does not buffer data, it can be interrupted at anytime.
 Depending on your architecture, it only requires about 40 bytes of data per
 message stream (in a web server that is per connection).")
     (license l:expat)))
+
+(define-public python2-httpretty
+  (package
+    (name "python2-httpretty")
+    (version "0.8.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "httpretty" version))
+       (sha256
+        (base32
+         "0vlp5qkyw3pxwwsg7xmdcfh1csvypvaz4m6abida8s4xmjxpdhc3"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-sphinx-rtd-theme" ,python2-sphinx-rtd-theme)
+       ("python-sphinx" ,python2-sphinx)
+       ("python-coverage" ,python2-coverage)
+       ("python-tornado" ,python2-tornado)
+       ("python-urllib3" ,python2-urllib3)
+       ("python-sure" ,python2-sure)
+       ("python-steadymark" ,python2-steadymark)
+       ("python-requests" ,python2-requests)
+       ("python-rednose" ,python2-rednose)
+       ("python-nose-randomly" ,python2-nose-randomly)
+       ("python-misaka" ,python2-misaka)
+       ("python-pytest-httpbin" ,python2-pytest-httpbin)
+       ("python-nose" ,python2-nose)))
+    (arguments
+     `(#:tests? #f
+       ;; Requires mock>=1.3.0 which requires a more up-to-date
+       ;; python-pbr. After updating these trying to build the
+       ;; package leads to failures in python-flake8 and other
+       ;; packages. The cascade of updates and failures this
+       ;; leads to, seems to not be worth having the test run.
+       #:python ,python-2
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'patch-test-requirements
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Update requirements from dependecy==version
+             ;; to dependency>=version
+             (substitute* "development.txt"
+               (("==") ">="))
+             #t)))))
+    (home-page "http://github.com/gabrielfalcao/httpretty")
+    (synopsis "HTTP client mock for Python")
+    (description "@code{httpretty} is a helper for faking web requests,
+inspired by Ruby's @code{fakeweb}.")
+    (license l:expat)))