summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-24 18:22:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-24 18:36:45 +0200
commit93ab7e8d527e0a648f78421d631350fcdbbaa93e (patch)
tree748cd6a480648f842058cbe97b275c1a451f2671 /gnu/packages/web.scm
parented1bbc16cc3b89a24c5d1e4523e49c0e03babd43 (diff)
downloadguix-93ab7e8d527e0a648f78421d631350fcdbbaa93e.tar.gz
gnu: tidy-html: Don't use unstable tarball.
* gnu/packages/web.scm (tidy-html)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3ee3d88f01..851c66b33e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5370,16 +5370,17 @@ used to start services with both privileged and non-privileged port numbers.")
     (version "5.6.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/htacg/tidy-html5/archive/"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/htacg/tidy-html5")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0n29wcgw32rhnraj9j21ibhwi0xagmmcskhbaz8ihxly7nx3p9h8"))))
+         "0w175c5d1babq0w1zzdzw9gl6iqbgyq58v8587s7srp05y3hwy9k"))))
     (build-system cmake-build-system)
     (outputs '("out"
-               "static"))               ; 1.0MiB of .a files
+               "static"))               ; 1.3MiB of .a files
     (arguments
      `(#:tests? #f                      ; no tests available
        #:build-type "Release"