summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-19 17:55:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-19 18:18:38 +0100
commitbed24ecfcd68ca6fbc21f02b477cffff3b4c0450 (patch)
tree99eae21f392f3056493778eba97d5d1c673cab87 /gnu/packages/web.scm
parent6305b039651d842e307d90c770c38e763fed2116 (diff)
downloadguix-bed24ecfcd68ca6fbc21f02b477cffff3b4c0450.tar.gz
gnu: arc-theme: Fix build.
* gnu/packages/web.scm (sassc/libsass-3.5): New public variable.
* gnu/packages/gnome.scm (arc-theme)[native-inputs]: Use it.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b2d282710a..032ba2206c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1516,6 +1516,7 @@ minimum to provide high performance operation.")
 (define-public libsass
   (package
     (name "libsass")
+    ;; When updating, check whether sassc/libsass-3.5 is still needed.
     (version "3.6.3")
     (source (origin
               (method git-fetch)
@@ -1595,6 +1596,29 @@ language known as SASS.")
     (home-page "https://sass-lang.com/libsass")
     (license license:expat)))
 
+(define-public sassc/libsass-3.5
+  ;; Newer libsass versions suffor from a memory leak when building (some?)
+  ;; GTK themes <https://github.com/sass/libsass/issues/3033>.
+  (package
+    (inherit sassc)
+    (name "sassc")
+    (inputs
+     `(("libsass" ,
+        (package
+          (inherit libsass)
+          (name "libsass")
+          (version "3.5.5")
+          (source
+           (origin
+             (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/sass/libsass.git")
+                   (commit version)))
+             (file-name (git-file-name name version))
+             (sha256
+              (base32
+               "0830pjcvhzxh6yixj82x5k5r1xnadjqzi16kp53213icbly0r9ma"))))))))))
+
 
 (define-public perl-apache-logformat-compiler
   (package