summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-06 12:18:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-06 13:56:25 +0200
commite0e0178f8e1e33f064e68994f236778441a6938c (patch)
treef4b8bb15190012f3c06e53d3deb3ea90b9f8f799 /gnu/packages/web.scm
parent39174fd7a7b76dd668e83439156a4478f151b1b7 (diff)
downloadguix-e0e0178f8e1e33f064e68994f236778441a6938c.tar.gz
gnu: nginx: Build http_xslt_module.
* gnu/packages/web.scm (nginx)[inputs]: Add libxml2 and libxslt.
[arguments]: Add "--with-http_xslt_module" to the configure flags.
Set up CFLAGS to find libxml2 headers.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 217e682bfa..cbc2754d71 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -376,7 +376,9 @@ the same, being completely separated from the Internet.")
                (base32
                 "121d11693d6dbim3lh64hrqi66z129z30cvcrpbnm631yl7jkl78"))))
     (build-system gnu-build-system)
-    (inputs `(("openssl" ,openssl)
+    (inputs `(("libxml2" ,libxml2)
+              ("libxslt" ,libxslt)
+              ("openssl" ,openssl)
               ("pcre" ,pcre)
               ("zlib" ,zlib)))
     (arguments
@@ -390,11 +392,12 @@ the same, being completely separated from the Internet.")
              #t))
          (replace 'configure
            ;; The configure script is hand-written, not from GNU autotools.
-           (lambda* (#:key configure-flags outputs #:allow-other-keys)
+           (lambda* (#:key configure-flags inputs outputs #:allow-other-keys)
              (let ((flags
                     (append (list (string-append "--prefix=" (assoc-ref outputs "out"))
                                   "--with-http_ssl_module"
                                   "--with-http_v2_module"
+                                  "--with-http_xslt_module"
                                   "--with-pcre-jit"
                                   "--with-debug"
                                   "--with-stream"
@@ -418,6 +421,10 @@ the same, being completely separated from the Internet.")
                                                     system ":" release ":" machine)))
                             configure-flags)))
                (setenv "CC" "gcc")
+               ;; Fix ./configure test for ‘#include <libxml/parser.h>’.
+               (setenv "CFLAGS"         ; CPPFLAGS is not respected
+                       (string-append "-I" (assoc-ref inputs "libxml2")
+                                      "/include/libxml2"))
                (format #t "configure flags: ~s~%" flags)
                (apply invoke "./configure" flags)
                #t)))