summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-11-12 03:15:52 -0500
committerLudovic Courtès <ludo@gnu.org>2022-11-28 23:34:15 +0100
commitf093291a1fac61c16d49007400c51d55ee54b84c (patch)
tree4013ff895d876e765d164241a5e11ba125334232 /gnu/packages/web.scm
parent5f42c018d64ad00023fc8c8279425c45bf99376b (diff)
downloadguix-f093291a1fac61c16d49007400c51d55ee54b84c.tar.gz
gnu: Add go-github-com-itchyny-timefmt-go.
* gnu/packages/web (go-github-com-itchyny-timefmt-go): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 61e1d1f1bc..7ff85b6bc1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4896,6 +4896,29 @@ little effort, and the program to do so is often shorter and simpler than
 you'd expect.")
     (license (list license:expat license:cc-by3.0))))
 
+(define-public go-github-com-itchyny-timefmt-go
+  (package
+    (name "go-github-com-itchyny-timefmt-go")
+    (version "0.1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/itchyny/timefmt-go")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0z5z8hy5lbjqdxp544mf238i77n7pf7bv3psgr5gffh0630dsyag"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/itchyny/timefmt-go"))
+    (home-page "https://github.com/itchyny/timefmt-go")
+    (synopsis "Efficient time formatting library (strftime, strptime) for Golang")
+    (description
+     "@code{timefmt-go} is a Go language package for formatting and parsing date
+time strings.")
+    (license license:expat)))
+
 (define-public pup
   (let ((revision "1")
         (commit "681d7bb639334bf485476f5872c5bdab10931f9a"))