summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-19 21:59:03 +0100
committerMarius Bakke <marius@gnu.org>2020-12-19 22:53:00 +0100
commitf6f6e1efeecd553c3af4c31695b17fb69849967b (patch)
treea474f9d3269fa864efe3090936e70b8805778459 /gnu/packages/web.scm
parentae7033ff5ff1d0d2571d808d40add0dd8e97bf8a (diff)
downloadguix-f6f6e1efeecd553c3af4c31695b17fb69849967b.tar.gz
gnu: serf: Build with Python 3.
* gnu/packages/patches/serf-python3.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/web.scm (serf)[source](patches): New field.
[arguments]: Remove #:scons.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 39820f7572..584003a1cf 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1792,6 +1792,7 @@ from streaming URLs.  It is a command-line wrapper for the libquvi library.")
        (method url-fetch)
        (uri (string-append "mirror://apache/serf/serf-"
                            version ".tar.bz2"))
+       (patches (search-patches "serf-python3.patch"))
        (sha256
         (base32 "1k47gbgpp52049andr28y28nbwh9m36bbb0g8p0aka3pqlhjv72l"))))
     (build-system scons-build-system)
@@ -1804,8 +1805,7 @@ from streaming URLs.  It is a command-line wrapper for the libquvi library.")
        ;;("gss" ,gss)
        ("zlib" ,zlib)))
     (arguments
-     `(#:scons ,scons-python2
-       #:scons-flags (list (string-append "APR=" (assoc-ref %build-inputs "apr"))
+     `(#:scons-flags (list (string-append "APR=" (assoc-ref %build-inputs "apr"))
                            (string-append "APU=" (assoc-ref %build-inputs "apr-util"))
                            (string-append "OPENSSL=" (assoc-ref %build-inputs "openssl"))
                            ;; (string-append "GSSAPI=" (assoc-ref %build-inputs "gss"))