summary refs log tree commit diff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-07 22:36:02 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-07 22:36:02 +0100
commitfea5ebb106e72b003dc66dfd77779dc09dd80e67 (patch)
tree357d3ad22d9ea8acdc3f91963d4323430208c8e3 /gnu/packages/web.scm
parentae2aa18dba62afbe911fb0f6b7ffdd52fa1b5d26 (diff)
downloadguix-fea5ebb106e72b003dc66dfd77779dc09dd80e67.tar.gz
gnu: Add perl-uri.
* gnu/packages/web.scm (perl-uri): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e18d49e99e..0bfa784717 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -129,3 +129,24 @@ are invoked.")
      "The HTTP::Date module provides functions that deal with date formats
 used by the HTTP protocol (and then some more).")
     (home-page "http://search.cpan.org/~gaas/HTTP-Date/")))
+
+(define-public perl-uri
+  (package
+    (name "perl-uri")
+    (version "1.60")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "mirror://cpan/authors/id/G/GA/GAAS/URI-"
+                   version ".tar.gz"))
+             (sha256
+              (base32
+               "0xr31mf7lfrwhyvlx4pzp6p7alls5gi4bj8pk5g89f5cckfd74hz"))))
+    (build-system perl-build-system)
+    (license (package-license perl))
+    (synopsis "Perl Uniform Resource Identifiers (absolute and relative)")
+    (description
+     "The URI module implements the URI class.  Objects of this class
+represent \"Uniform Resource Identifier references\" as specified in RFC 2396
+(and updated by RFC 2732).")
+    (home-page "http://search.cpan.org/~gaas/URI/")))