summary refs log tree commit diff
path: root/gnu/packages/weechat.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-18 17:35:14 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-18 17:47:09 +0100
commite33cf9a69ae20d6d3098a1287d9247b1e32c7402 (patch)
tree479f982a85a79f959f19105b8aa2ee686d25d63b /gnu/packages/weechat.scm
parentf4a4a71885f5ad6db36f8b83a1b87e86d2dbbea4 (diff)
downloadguix-e33cf9a69ae20d6d3098a1287d9247b1e32c7402.tar.gz
gnu: weechat: Use 'modify-phases'.
* gnu/packages/weechat.scm (weechat)[arguments]: Use 'modify-phases'.
  Remove 'fix-file' phase.
Diffstat (limited to 'gnu/packages/weechat.scm')
-rw-r--r--gnu/packages/weechat.scm30
1 files changed, 12 insertions, 18 deletions
diff --git a/gnu/packages/weechat.scm b/gnu/packages/weechat.scm
index d88ad53166..18508dd09d 100644
--- a/gnu/packages/weechat.scm
+++ b/gnu/packages/weechat.scm
@@ -47,11 +47,11 @@
     (name "weechat")
     (version "1.3")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "http://weechat.org/files/src/weechat-"
+              (method url-fetch)
+              (uri (string-append "http://weechat.org/files/src/weechat-"
                                   version ".tar.gz"))
-             (sha256
-              (base32 "13b7dfs3sn71c51fi0bli5rzlsppil6gg1lzik3k8l43yhhqyv2w"))))
+              (sha256
+               (base32 "13b7dfs3sn71c51fi0bli5rzlsppil6gg1lzik3k8l43yhhqyv2w"))))
     (build-system gnu-build-system)
     (native-inputs `(("autoconf" ,autoconf)
                      ("pkg-config" ,pkg-config)
@@ -75,20 +75,14 @@
               ("python" ,python-2)
               ("perl" ,perl)
               ("tcl" ,tcl)))
-    (arguments `(#:configure-flags (list
-                                    (string-append
-                                     "--with-tclconfig="
-                                     (assoc-ref %build-inputs "tcl") "/lib"))
-                 #:phases (alist-cons-after
-                           'autogen 'fix-file
-                           (lambda _
-                             (substitute* "configure"
-                               (("/usr/bin/file") (which "file"))))
-                           (alist-cons-before
-                            'configure 'autogen
-                            (lambda _
-                              (zero? (system* "./autogen.sh")))
-                            %standard-phases))))
+    (arguments
+     `(#:configure-flags (list (string-append
+                                "--with-tclconfig="
+                                (assoc-ref %build-inputs "tcl") "/lib"))
+       #:phases (modify-phases %standard-phases
+                  (add-before 'configure 'autogen
+                    (lambda _
+                      (zero? (system* "./autogen.sh")))))))
     (synopsis "Extensible chat client")
     (description "WeeChat (Wee Enhanced Environment for Chat) is an
 Internet Relay Chat client, which is designed to be light and fast.