summary refs log tree commit diff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-26 04:36:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-26 04:36:02 +0200
commit7342923d98cbefec61c2d67ce916d83d42f4bc3e (patch)
tree7100eacfd00a0a018a7ff64540e8b730bc8006a2 /gnu/packages/wget.scm
parent4f7db085711431b277ea7e1ba2a806751a84cd20 (diff)
downloadguix-7342923d98cbefec61c2d67ce916d83d42f4bc3e.tar.gz
gnu: wgetpaste: Add and use wget input.
This package has but one purpose; late binding's overkill.

* gnu/packages/wget.scm (wgetpaste)[arguments]: Add ‘use-inputs’ phase.
[inputs]: Add wget.
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 128041318b..4f8671ad6e 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -93,6 +93,13 @@ in downloaded documents to relative links.")
        (modify-phases %standard-phases
          (delete 'configure)
          (delete 'build)
+         (add-before 'install 'use-inputs
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let* ((wget (assoc-ref inputs "wget")))
+               (substitute* "wgetpaste"
+                 (("(LC_ALL=C) wget" _ prefix)
+                  (format "~a ~a/bin/wget" prefix wget)))
+               #t)))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -100,7 +107,9 @@ in downloaded documents to relative links.")
                     (zsh (string-append out "/share/zsh/site-functions")))
                (install-file "wgetpaste" bin)
                (install-file "_wgetpaste" zsh)))))
-       #:tests? #f)) ; no test target
+       #:tests? #f))                    ; no test target
+    (inputs
+     `(("wget" ,wget)))
     (home-page "http://wgetpaste.zlin.dk/")
     (synopsis "Script that automates pasting to a number of pastebin services")
     (description