summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-03-11 20:19:41 +0100
committerRutger Helling <rhelling@mykolab.com>2019-03-11 20:28:41 +0100
commit06ae5efcf385312faec3e6280786bc7b4aa63978 (patch)
tree277f58b2932f5b215c520cf14f2a479d77f6cc53 /gnu/packages/wm.scm
parent2ff844f0900be711be2322258beadeaa68e7b8b7 (diff)
downloadguix-06ae5efcf385312faec3e6280786bc7b4aa63978.tar.gz
gnu: Add swayidle.
* gnu/packages/wm.scm (swayidle): New variable.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index fedea67cc4..fe4e0f404f 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1198,3 +1198,26 @@ modules for building a Wayland compositor.")
     (synopsis "Wayland compositor compatible with i3")
     (description "Sway is a i3-compatible Wayland compositor.")
     (license license:expat)))       ; MIT license
+
+(define-public swayidle
+  (package
+    (name "swayidle")
+    (version "1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/swaywm/swayidle.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0b65flajwn2i6k2kdxxgw25w7ikzzmm595f4j5x1wac1rb0yah9w"))))
+    (build-system meson-build-system)
+    (inputs `(("wayland" ,wayland)))
+    (native-inputs `(("pkg-config" ,pkg-config)
+                     ("scdoc" ,scdoc)
+                     ("wayland-protocols" ,wayland-protocols)))
+    (home-page "https://github.com/swaywm/sway")
+    (synopsis "Idle management daemon for Wayland compositors")
+    (description "Swayidle is a idle management daemon for Wayland compositors.")
+    (license license:expat))) ; MIT license