summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-19 23:12:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 04:50:19 +0200
commitaa0551c270abe45cf36c2fda80a15351fbcaba3b (patch)
tree5dccc95d8d550788c6139a5f18460e676ebeee9d /gnu/packages/wm.scm
parentd6331fcaa603b18726fc166561d7c4c88e2c9b13 (diff)
downloadguix-aa0551c270abe45cf36c2fda80a15351fbcaba3b.tar.gz
gnu: bspwm: Update to 0.9.5.
* gnu/packages/wm.scm (bspwm): Update to 0.9.5.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a3705c9d91..2a09521601 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -103,7 +103,7 @@ nested include statements).")
 (define-public bspwm
   (package
     (name "bspwm")
-    (version "0.9.4")
+    (version "0.9.5")
     (source
      (origin
        (file-name (string-append name "-" version ".tar.gz"))
@@ -113,7 +113,7 @@ nested include statements).")
              version ".tar.gz"))
        (sha256
         (base32
-         "0yjr0vzbj3ar8qfr6gvpvjd82ay8iy1sg2fkw2swghlqiy6ix4kw"))))
+         "10pph8wxqysgk7b2h0svs0nwacn1a4y44jnzzry32pd1ysx92d97"))))
     (build-system gnu-build-system)
     (inputs
      `(("libxcb" ,libxcb)
@@ -123,10 +123,13 @@ nested include statements).")
        ("xcb-util-keysyms" ,xcb-util-keysyms)
        ("xcb-util-wm" ,xcb-util-wm)))
     (arguments
-     '(#:phases (modify-phases %standard-phases (delete 'configure))
-       #:tests? #f  ; no check target
-       #:make-flags (list "CC=gcc"
-                          (string-append "PREFIX=" %output))))
+     '(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure))           ; no configure script
+       #:tests? #f                      ; no check target
+       #:make-flags
+       (list "CC=gcc"
+             (string-append "PREFIX=" %output))))
     (home-page "https://github.com/baskerville/bspwm")
     (synopsis "Tiling window manager based on binary space partitioning")
     (description "bspwm is a tiling window manager that represents windows as