summary refs log tree commit diff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-21 14:31:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-21 14:31:36 +0100
commit8505eb19a4071f563811d4fe33471441c2db58b7 (patch)
tree123241c704e7d1a88eb4efe2793a6898e2e72216 /gnu/packages/xdisorg.scm
parent3b88f3767d9f3ad2cc64173525cd53d429bfe7e7 (diff)
parentb097a3387ea78797104f97eef445f5da6278c922 (diff)
downloadguix-8505eb19a4071f563811d4fe33471441c2db58b7.tar.gz
Merge branch 'staging' into core-updates
Conflicts:
	gnu/local.mk: Missing mention of gdk-pixbuf-list-dir.patch in the
	commit log really confused me here... It's from 8c6b077bfae (staging).
	gnu/packages/xorg.scm: xkeyboard-config updated both places.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a1c89a5caa..7b3142657f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -138,14 +138,14 @@ avoiding password prompts when X11 forwarding has already been setup.")
 (define-public libxkbcommon
   (package
     (name "libxkbcommon")
-    (version "0.6.1")
+    (version "0.7.1")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://xkbcommon.org/download/" name "-"
+             (uri (string-append "https://xkbcommon.org/download/" name "-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0q47xa1szlxwgvwmhv4b7xwawnykz1hnc431d84nj8dlh2q8f22v"))))
+               "12z6hih3n1r0asp2hzp9qsiwdfkfz46jwp06x8kprr0r5rfk0nds"))))
     (build-system gnu-build-system)
     (inputs
      `(("libx11" ,libx11)
@@ -162,7 +162,7 @@ avoiding password prompts when X11 forwarding has already been setup.")
              (string-append "--with-x-locale-root="
                             (assoc-ref %build-inputs "libx11")
                             "/share/X11/locale"))))
-    (home-page "http://xkbcommon.org/")
+    (home-page "https://xkbcommon.org/")
     (synopsis "Library to handle keyboard descriptions")
     (description "Xkbcommon is a library to handle keyboard descriptions,
 including loading them from disk, parsing them and handling their
@@ -273,7 +273,7 @@ rasterisation.")
 (define-public libdrm
   (package
     (name "libdrm")
-    (version "2.4.68")
+    (version "2.4.75")
     (source
       (origin
         (method url-fetch)
@@ -283,7 +283,7 @@ rasterisation.")
                ".tar.bz2"))
         (sha256
          (base32
-          "1px91j6imaaq2fy8ksvgldmv0cdz3w379jqiciqvqa99jajxjjsv"))
+          "0kq5hmck0gq7b29fr8jp94njc7jpkpbyws12s63w4b21xw750nid"))
         (patches (search-patches "libdrm-symbol-check.patch"))))
     (build-system gnu-build-system)
     (inputs