summary refs log tree commit diff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-02-27 23:50:33 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-03-19 18:43:41 +0800
commita356eb7b9461f7ae5e57ccda1dd1114e1e388fa1 (patch)
tree77b1797b9e1ef97f1ec77fbe8bec5f72e209ef20 /gnu/packages/xdisorg.scm
parentd67b764ceb0da86a198ef692b162c80090f43af7 (diff)
downloadguix-a356eb7b9461f7ae5e57ccda1dd1114e1e388fa1.tar.gz
gnu: sxhkd: Use Gexps.
* gnu/packages/xdisorg.scm(sxhkd)[arguments]: Use Gexps.

Change-Id: Ib2379193014fdfe21de161691dac46d6e9feb758
Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 169d6a9c42..cd30b6661e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -41,7 +41,7 @@
 ;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020, 2021, 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021, 2023, 2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021, 2022, 2024 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
@@ -1343,14 +1343,14 @@ Guile will work for XBindKeys.")
     (inputs
      (list asciidoc libxcb xcb-util xcb-util-keysyms xcb-util-wm))
     (arguments
-     `(#:phases (modify-phases %standard-phases (delete 'configure))
-       #:tests? #f  ; no check target
-       #:make-flags
-       (list ,(string-append "CC=" (cc-for-target))
-             (string-append "PREFIX=" %output)
-             ;; Keep the documentation where the build system installs LICENSE.
-             (string-append "DOCPREFIX=" %output
-                            "/share/doc/" ,name "-" ,version))))
+     (list #:phases #~(modify-phases %standard-phases (delete 'configure))
+           #:tests? #f  ; no check target
+           #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "PREFIX=" #$output)
+                   ;; Keep the documentation where the build system installs LICENSE.
+                   (string-append "DOCPREFIX=" #$output
+                                  "/share/doc/" #$name "-" #$version))))
     (home-page "https://github.com/baskerville/sxhkd")
     (synopsis "Simple X hotkey daemon")
     (description "sxhkd is a simple X hotkey daemon with a powerful and