summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 15:54:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-12 23:23:25 -0400
commit023259c4bd1a38225fb1c06660c0cf393210e811 (patch)
tree21a5c7a3e27ca92a2f3947b32d164f167f1ce2f8 /gnu/packages/xfce.scm
parent73d7247aacecbbe330203105b260a58683709063 (diff)
downloadguix-023259c4bd1a38225fb1c06660c0cf393210e811.tar.gz
gnu: inkscape: Rename variable to inkscape/stable and hide package.
This will allow introducing a new 'inkscape' package that can be more freely
upgraded on the main branch.

* gnu/packages/inkscape.scm (inkscape): Rename to...
(inkscape/stable): ... this, and make it a hidden package.
* gnu/packages/admin.scm (wpa-supplicant-gui)[native-inputs]: Rename inkscape
input accordingly.
* gnu/packages/docbook.scm (dblatex): Likewise.
* gnu/packages/gnome-xyz.scm (arc-theme): Likewise.
* gnu/packages/python-xyz.scm (python-matplotlib-documentation): Likewise.
(python-nbconvert): Likewise.
* gnu/packages/xfce.scm (xfdesktop): Likewise.
* gnu/packages/xorg.scm (hackneyed-x11-cursors): Likewise.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index ddd484b165..323ecd3042 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -862,11 +862,11 @@ on the screen.")
                                   "backgrounds/xfce-verticals.png"))
                       #t)))
 
-       #:disallowed-references (,inkscape ,imagemagick)))
+       #:disallowed-references (,inkscape/stable ,imagemagick)))
     (native-inputs
      (list pkg-config intltool
            ;; For our own ‘prepare-background-image’ phase.
-           inkscape imagemagick))
+           inkscape/stable imagemagick))
     (inputs
      (list exo
            garcon