summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:32 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:29:34 +0200
commit18af33827bb446b09605d29b2e8ea0e3106d6da4 (patch)
tree1247660fe037df20d2e86d472be37b1fc742a699 /gnu/packages/xfce.scm
parent2f81e67850502394d17ac7e74d23cdf8ee215516 (diff)
downloadguix-18af33827bb446b09605d29b2e8ea0e3106d6da4.tar.gz
gnu: Add xfce4-cpufreq-plugin.
* gnu/packages/xfce.scm (xfce4-cpufreq-plugin): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 9aaabe02c6..510fa78260 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1345,6 +1345,33 @@ supports common mathematical operators (+, -, *, /, ^) with usual
 precedence rules, and the following functions and common constants.")
     (license gpl2+)))
 
+(define-public xfce4-cpufreq-plugin
+  (package
+   (name "xfce4-cpufreq-plugin")
+   (version "1.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  "xfce4-cpufreq-plugin/"
+                                  (version-major+minor version)
+                                  "/xfce4-cpufreq-plugin-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1dgmx3ygil51s1az298ly0gybcw8ln1dz8q8y9k207a0vk049q65"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page
+     "https://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin")
+    (synopsis "Xfce panel plugin for displaying CPU frequency")
+    (description "This panel plugin shows information about the CPU
+governor and frequencies supported and used by your system.")
+    (license gpl2+)))
+
 (define-public xfce4-embed-plugin
   (package
    (name "xfce4-embed-plugin")