summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2022-01-04 16:50:57 +0100
committer宋文武 <iyzsong@member.fsf.org>2023-08-25 18:13:32 +0800
commit1c916c167b7eb1f2f8af2cf621aa1512b00b1033 (patch)
tree673d73febc27f16cbe4922bb747254818af4cf1c /gnu/packages/xfce.scm
parent5c8e8dff607da710ce13a506e2dc42e98ee96737 (diff)
downloadguix-1c916c167b7eb1f2f8af2cf621aa1512b00b1033.tar.gz
gnu: Add thunarx-python.
* gnu/packages/xfce.scm (thunarx-python): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 705fbecfeb..fed7360aa8 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -891,6 +891,34 @@ GIT integration to Thunar, it adds Subversion and GIT actions to the context
 menu.")
     (license gpl2+)))
 
+(define-public thunarx-python
+  (package
+    (name "thunarx-python")
+    (version "0.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://archive.xfce.org/src/bindings/"
+                           name "/" (version-major+minor version)
+                           "/" name "-" version ".tar.bz2"))
+       (sha256
+        (base32 "08lz9pvx006a2fypg2q38p61jbhy0yswz8cizlxpiwfcqsvhpnln"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list pkg-config which))
+    (inputs
+     (list exo
+           thunar
+           python
+           python-pygobject
+           libxfce4ui
+           gtk+))
+    (home-page "https://gitlab.xfce.org/bindings/thunarx-python")
+    (synopsis "Python Bindings for Thunar")
+    (description
+     "These bindings allow one to create python plugins for Thunar.")
+    (license gpl2+)))
+
 (define-public xfwm4
   (package
     (name "xfwm4")