summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:28 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:28:04 +0200
commit58253d9f5b02452424a5f73246be40af95309195 (patch)
treebe8254fa348a7af2391615870e9fbeb7e1977276 /gnu/packages/xfce.scm
parent7e53f357ac9387b50b3f110dcf2d5db6c712f30c (diff)
downloadguix-58253d9f5b02452424a5f73246be40af95309195.tar.gz
gnu: Add xfce4-eyes-plugin.
* gnu/packages/xfce.scm (xfce4-eyes-plugin): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 199e1faf97..62686f5ece 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1263,6 +1263,33 @@ display all of them at once, or at the user's option only a specific
 core or CPU.")
     (license gpl2+)))
 
+(define-public xfce4-eyes-plugin
+  (package
+   (name "xfce4-eyes-plugin")
+   (version "4.5.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  "xfce4-eyes-plugin/"
+                                  (version-major+minor version)
+                                  "/xfce4-eyes-plugin-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "17gj6fbvvrdzvz61czmia8hqynllsnmhk61fs4aml443cc1h1bpx"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page
+     "https://goodies.xfce.org/projects/panel-plugins/xfce4-eyes-plugin")
+    (synopsis "Display a pair of eyes for the Xfce panel")
+    (description "Eyes is a toy Xfce panel plugin that adds eyes which
+watch your every step.")
+    (license gpl2+)))
+
 (define-public xfce4-mount-plugin
   (package
    (name "xfce4-mount-plugin")