summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorL p R n d n <guix@lprndn.info>2019-09-02 16:06:59 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-07 00:36:34 +0200
commit8cc5d3dc4d3c66d19d14b65f75afbfe4a695b6af (patch)
tree33c58255872c4c70de30091f2b8fd0432fdea815 /gnu/packages/xfce.scm
parent64200f01973e3eb0b9b5a49c7ac24bf5f75aa1b1 (diff)
downloadguix-8cc5d3dc4d3c66d19d14b65f75afbfe4a695b6af.tar.gz
gnu: xfce4-panel: Fix tzdata path.
* gnu/packages/xfce.scm (xfce4-panel)[inputs]: Add tzdata.
[arguments] Add Fix-tzdata-path phase.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 512ca35fe9..0487c24b68 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -37,6 +37,7 @@
   #:use-module (guix build-system trivial)
   #:use-module (gnu artwork)
   #:use-module (gnu packages)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages cdrom)
   #:use-module (gnu packages pkg-config)
@@ -309,6 +310,15 @@ management D-Bus specification.")
                 "1x3flv86jh9vqah7mr5mmfx2991mc6icsqjygsc3j88lgsyz7y6m"))
               (patches (search-patches "xfce4-panel-plugins.patch"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-tzdata-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* (string-append "plugins/clock/clock.c")
+               (("/usr/share/zoneinfo")
+                (string-append (assoc-ref inputs "tzdata") "/share/zoneinfo")))
+             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)
@@ -317,7 +327,8 @@ management D-Bus specification.")
      `(("gtk+-3" ,gtk+)                 ; required by libxfce4panel-2.0.pc
        ("libxfce4util" ,libxfce4util))) ; required by libxfce4panel-2.0.pc
     (inputs
-     `(("exo" ,exo)
+     `(("tzdata" ,tzdata) ;; For fix-tzdata-path phase only.
+       ("exo" ,exo)
        ("gtk+-2" ,gtk+-2)
        ("xfconf" ,xfconf)
        ("garcon" ,garcon)