summary refs log tree commit diff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:35 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:30:04 +0200
commita004609a1315969b9f78ac8ce104653758c2b6a3 (patch)
treef4ee16cc87efac49d2eb5c866346299cff2234bc /gnu/packages/xfce.scm
parent2aee1fef0bef7eed58f1c68f8996affa22149b2c (diff)
downloadguix-a004609a1315969b9f78ac8ce104653758c2b6a3.tar.gz
gnu: Add xfce4-mpc-plugin.
* gnu/packages/xfce.scm (xfce4-mpc-plugin): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 5b4ebaf603..bf1e84366e 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1464,6 +1464,49 @@ urgent limit that advise the user with a message.  The icon button can
 be clicked to open the chosen mount point.")
     (license bsd-2)))
 
+(define-public xfce4-mpc-plugin
+  (package
+   (name "xfce4-mpc-plugin")
+   (version "0.5.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+                                  "xfce4-mpc-plugin/"
+                                  (version-major+minor version)
+                                  "/xfce4-mpc-plugin-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0q3pysdp85b3c7g3b59y3c69g4nw6bvbf518lnri4lxrnsvpizpf"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxfce4ui" ,libxfce4ui)
+       ("xfce4-panel" ,xfce4-panel)))
+    (home-page "https://goodies.xfce.org/projects/panel-plugins/xfce4-mpc-plugin")
+    (synopsis "Music Player Daemon plugin for the Xfce panel")
+    (description "This is a simple client plugin for Music Player Daemon.
+
+Features:
+@itemize
+@item send Play/Stop/Next/Previous command to MPD.
+@item uses media icons names from icon-naming-spec (at least nuvola,
+tango and rodent themes provides these icons)
+@item decrease/increase volume using the mouse wheel.
+@item show the current volume, status and title as a tooltip when
+hovering the mouse over the plugin.
+@item show a simple playlist window upon middle-click, permitting to
+select a track to play
+@item configurable MPD host/port/password.
+@item toggles repeat/random features + enable/disable MPD outputs in
+the right-click menu.
+@item launch configurable client (gmpc, xterm -e ncmpc,..) through
+right-click menu
+@item configurable markup for tooltip and playlist, using a gmpc-like markup
+@end itemize")
+    (license isc)))
+
 (define-public xfce4-mount-plugin
   (package
    (name "xfce4-mount-plugin")