summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-07 12:01:33 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-07 12:01:33 +0200
commit3c9e0ddc6f812006df237950bf00e872056b52e0 (patch)
tree3f401b2d77ed3ef235c18284d00c792c13396303 /gnu/packages/xml.scm
parentaeafff536f933b07836b14d089dfc52b0e432ec9 (diff)
downloadguix-3c9e0ddc6f812006df237950bf00e872056b52e0.tar.gz
gnu: libxml2: Upgrade to 2.9.4.
* gnu/packages/xml.scm (libxml2)[replacement]: Remove.
[version, source]: Upgrade to 2.9.4.
(libxml2/fixed): Remove.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 5b72c805bd..a860f98053 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -66,15 +66,14 @@ things the parser might find in the XML document (like start tags).")
 (define-public libxml2
   (package
     (name "libxml2")
-    (version "2.9.3")
-    (replacement libxml2/fixed)                   ;multiple CVEs
+    (version "2.9.4")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://xmlsoft.org/libxml2/libxml2-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0bd17g6znn2r98gzpjppsqjg33iraky4px923j3k8kdl8qgy7sad"))))
+               "0g336cr0bw6dax1q48bblphmchgihx9p1pjmxdnrd6sh3qci3fgz"))))
     (build-system gnu-build-system)
     (home-page "http://www.xmlsoft.org/")
     (synopsis "C parser for XML")
@@ -94,20 +93,6 @@ things the parser might find in the XML document (like start tags).")
 project (but it is usable outside of the Gnome platform).")
     (license license:x11)))
 
-(define libxml2/fixed
-  (package
-    (inherit libxml2)
-    (source
-     (let ((name "libxml2")
-           (version "2.9.4"))
-       (origin
-         (method url-fetch)
-         (uri (string-append "ftp://xmlsoft.org/libxml2/libxml2-"
-                             version ".tar.gz"))
-         (sha256
-          (base32
-           "0g336cr0bw6dax1q48bblphmchgihx9p1pjmxdnrd6sh3qci3fgz")))))))
-
 (define-public python-libxml2
   (package (inherit libxml2)
     (name "python-libxml2")