summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:01 +0200
commit3fae4f64bafee61d335e42aa83a112328654f329 (patch)
treeeedc12356beac7d86c9f6d7f65a02d4e83dd4263 /gnu/packages/xml.scm
parentfa1cd5b31fc2fce77beb4bb4eac2fdbc4cae1071 (diff)
downloadguix-3fae4f64bafee61d335e42aa83a112328654f329.tar.gz
gnu: xlsxio: Use G-expressions.
* gnu/packages/xml.scm (xlsxio)[arguments]:
Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 6ea2ead555..855d2b3d47 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1531,15 +1531,16 @@ SAX2 APIs.")
      (list expat gnu-make minizip which))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (delete 'check)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (invoke "make" "install"
-                     (string-append
-                      "PREFIX=" (assoc-ref outputs "out"))))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (delete 'check)
+          (replace 'install
+            (lambda* (#:key outputs #:allow-other-keys)
+              (invoke "make" "install"
+                      (string-append
+                       "PREFIX=" (assoc-ref outputs "out"))))))))
     (synopsis "C library for reading and writing .xlsx files")
     (description "XLSX I/O aims to provide a C library for reading and writing
 .xlsx files.  The .xlsx file format is the native format used by Microsoft(R)