summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-09-12 16:54:45 -0400
committerLeo Famulari <leo@famulari.name>2016-09-27 13:49:49 -0400
commitb9bc6e842066b066ebdf9eaf75d41753598d75b5 (patch)
tree2914357fecc98ff6f39b86a6d3e5519b22fe634c /gnu/packages/xml.scm
parent32f70e1f86141ed30f1026ea0cf8a4bd377004b0 (diff)
downloadguix-b9bc6e842066b066ebdf9eaf75d41753598d75b5.tar.gz
gnu: expat: Fix regression caused by fix for CVE-2016-0718.
* gnu/packages/xml.scm (expat)[replacement]: New field.
(expat/fixed): New variable.
* gnu/packages/patches/expat-CVE-2016-0718-fix-regression.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index cd3426b55f..879b37a337 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -52,6 +52,7 @@
 (define-public expat
   (package
     (name "expat")
+    (replacement expat/fixed)
     (version "2.1.1")
     (source (origin
              (method url-fetch)
@@ -72,6 +73,17 @@ stream-oriented parser in which an application registers handlers for
 things the parser might find in the XML document (like start tags).")
     (license license:expat)))
 
+(define expat/fixed
+  (package
+    (inherit expat)
+    (source (origin
+              (inherit (package-source expat))
+              (patches (search-patches
+                         "expat-CVE-2012-6702-and-CVE-2016-5300.patch"
+                         "expat-CVE-2015-1283-refix.patch"
+                         "expat-CVE-2016-0718.patch"
+                         "expat-CVE-2016-0718-fix-regression.patch"))))))
+
 (define-public libxml2
   (package
     (name "libxml2")