summary refs log tree commit diff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-22 16:14:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:40 +0100
commitc1d41b5df33a164b0bbfd0dbb9bdb897ee473660 (patch)
tree3b41ef182d1161c0b937498da499f26b60f805f7 /gnu/packages/xml.scm
parentf7c4dc2f55ff2b984577dde17d1c08c7cbcad113 (diff)
downloadguix-c1d41b5df33a164b0bbfd0dbb9bdb897ee473660.tar.gz
gnu: Add XML::Compile::Cache.
* gnu/packages/xml.scm (perl-xml-compile-cache): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index c46f4d465b..7eada2bcbb 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -444,6 +444,29 @@ XML or XML into a Perl data-structure, both directions under rigid control by
 a schema.")
     (license (package-license perl))))
 
+(define-public perl-xml-compile-cache
+  (package
+    (name "perl-xml-compile-cache")
+    (version "1.04")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/M/MA/MARKOV/"
+                                  "XML-Compile-Cache-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1689dm54n7wb0n0cl9n77vk0kvg0mcckn2hz9ahigjhvazah8740"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-log-report" ,perl-log-report)
+       ("perl-xml-compile" ,perl-xml-compile)
+       ("perl-xml-compile-tester" ,perl-xml-compile-tester)
+       ("perl-xml-libxml-simple" ,perl-xml-libxml-simple)))
+    (home-page "http://search.cpan.org/dist/XML-Compile-Cache")
+    (synopsis "Cache compiled XML translators")
+    (description
+     "This package provides methods to cache compiled XML translators.")
+    (license (package-license perl))))
+
 (define-public pugixml
   (package
     (name "pugixml")