summary refs log tree commit diff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-06-25 05:20:36 -0400
committerMark H Weaver <mhw@netris.org>2017-06-28 06:14:59 -0400
commitb049ae2f9708794f83c41171c19ffdfe4f11807e (patch)
tree25ab53947f466d703c2645fee7c1d7d9e9b57fe1 /gnu/packages/xorg.scm
parentd07d29280881774d9bf299793dd762824a74082f (diff)
downloadguix-b049ae2f9708794f83c41171c19ffdfe4f11807e.tar.gz
gnu: xf86-video-intel: Use UXA accel method by default.
* gnu/packages/xorg.scm (xf86-video-intel)[arguments]: Add #:configure-flags
with "--with-default-accel=uxa".
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d4da5d7098..c6d1946220 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
@@ -2849,7 +2849,8 @@ X server.")
                                     (string-prefix? "x86_64-" system)))
                %supported-systems))
       (arguments
-       '(#:phases (modify-phases %standard-phases
+       '(#:configure-flags '("--with-default-accel=uxa")
+         #:phases (modify-phases %standard-phases
                     (add-after 'unpack 'bootstrap
                       (lambda _
                         (zero? (system* "autoreconf" "-vfi")))))))