summary refs log tree commit diff
path: root/gnu/packages/zip.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-04-01 17:36:30 -0400
committerMark H Weaver <mhw@netris.org>2014-04-02 11:27:38 -0400
commit757577896968057cf175e912296ae74015e2d957 (patch)
tree6c48c4a63b5f900913b3311e63a2289ef5cff6dc /gnu/packages/zip.scm
parenta2c03fb1afe133acba7593005e0aa4729960fc0e (diff)
downloadguix-757577896968057cf175e912296ae74015e2d957.tar.gz
gnu: zip: Improve build process and install man pages in share/man.
* gnu/packages/zip.scm (zip): Eliminate custom configure phase which copied
  and patched the Makefile.  Instead add "-f" and "prefix" to make-flags, as
  well as "MANDIR".  Remove "generic_gcc" from the make-flags, so that it will
  not be passed during other phases involving 'make'.  Instead replace the
  'build' phase with one that specifies the "generic_gcc" target.
Diffstat (limited to 'gnu/packages/zip.scm')
-rw-r--r--gnu/packages/zip.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/zip.scm b/gnu/packages/zip.scm
index 03f3bc22ea..1e1d29e1b7 100644
--- a/gnu/packages/zip.scm
+++ b/gnu/packages/zip.scm
@@ -43,15 +43,15 @@
     (inputs `(("bzip2" ,bzip2)))
     (arguments
      `(#:tests? #f ; no test target
-       #:make-flags '("generic_gcc")
-       #:phases
-        (alist-replace
-         'configure
-         (lambda* (#:key outputs #:allow-other-keys)
-           (let* ((out (assoc-ref outputs "out")))
-             (copy-file "unix/Makefile" "Makefile")
-             (substitute* "Makefile" (("/usr/local") out))))
-        %standard-phases)))
+       #:make-flags (let ((out (assoc-ref %outputs "out")))
+                      (list "-f" "unix/Makefile"
+                            (string-append "prefix=" out)
+                            (string-append "MANDIR=" out "/share/man/man1")))
+       #:phases (alist-replace
+                 'build
+                 (lambda* (#:key (make-flags '()) #:allow-other-keys)
+                   (zero? (apply system* "make" "generic_gcc" make-flags)))
+                 (alist-delete 'configure %standard-phases))))
     (home-page "http://www.info-zip.org/Zip.html")
     (synopsis "Zip compression and file packing utility")
     (description