summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2023-07-15 17:13:21 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-08-02 22:27:43 +0800
commit02f4e43b9f78a7238b03f9c79c6fa3db7e5ed1c7 (patch)
tree2d9703ea2f5a0bb6c6ea56ccbac025df083f2150 /gnu/packages
parentbbf7c10e5dddb991197c2095362d24c1543b2404 (diff)
downloadguix-02f4e43b9f78a7238b03f9c79c6fa3db7e5ed1c7.tar.gz
gnu: kscreenlocker: Format with 'guix style'.
* gnu/packages/kde-plasma.scm (kscreenlocker): Adjust package formatting
with 'guix style'.
[arguments]: Use G-expressions, remove tail #t.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-plasma.scm91
1 files changed, 43 insertions, 48 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 9062fc7911..4e57202912 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -835,54 +835,49 @@ an elegant and intuitive experience for your tasks and plasmoids.")
                 "0pgmy4dw41kim7syk4xb2n4g4iz3jjikhwnh3bjianl9h87rc12x"))))
     (build-system qt-build-system)
     (arguments
-     `(#:tests? #f ;; TODO: make tests pass
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'check-setup
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (system "Xvfb :1 -screen 0 640x480x24 &")
-             (setenv "DISPLAY" ":1")
-             #t))
-         (delete 'check)
-         ;; Tests use the installed library and require a DBus session.
-         (add-after 'install 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (if tests?
-                 (begin
-                   (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
-                   (invoke "dbus-launch" "ctest")))
-             #t)))))
-    (native-inputs
-     (list extra-cmake-modules pkg-config
-           ;; For tests.
-           dbus xorg-server-for-tests))
-    (inputs
-     (list kcmutils
-           kconfig
-           kcrash
-           kdeclarative
-           kglobalaccel
-           ki18n
-           kio
-           kidletime
-           knotifications
-           ktextwidgets
-           kwayland
-           kwindowsystem
-           kxmlgui
-           layer-shell-qt
-           libkscreen
-           libseccomp ;for sandboxing the look'n'feel package
-           libxcursor ;missing in CMakeList.txt
-           libxi ;XInput, required for grabbing XInput2 devices
-           linux-pam
-           elogind ;optional loginctl support
-           qtbase-5
-           qtdeclarative-5
-           qtx11extras
-           solid
-           wayland
-           xcb-util-keysyms))
+     (list #:tests? #f ;TODO: make tests pass
+           #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'check-setup
+                          (lambda* (#:key inputs outputs #:allow-other-keys)
+                            (system "Xvfb :1 -screen 0 640x480x24 &")
+                            (setenv "DISPLAY" ":1")))
+                        (delete 'check)
+                        ;; Tests use the installed library and require a DBus session.
+                        (add-after 'install 'check
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (if tests?
+                                (begin
+                                  (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
+                                  (invoke "dbus-launch" "ctest"))))))))
+    (native-inputs (list extra-cmake-modules pkg-config
+                         ;; For tests.
+                         dbus xorg-server-for-tests))
+    (inputs (list kcmutils
+                  kconfig
+                  kcrash
+                  kdeclarative
+                  kglobalaccel
+                  ki18n
+                  kio
+                  kidletime
+                  knotifications
+                  ktextwidgets
+                  kwayland
+                  kwindowsystem
+                  kxmlgui
+                  layer-shell-qt
+                  libkscreen
+                  libseccomp ;for sandboxing the look'n'feel package
+                  libxcursor ;missing in CMakeList.txt
+                  libxi ;XInput, required for grabbing XInput2 devices
+                  linux-pam
+                  elogind ;optional loginctl support
+                  qtbase-5
+                  qtdeclarative-5
+                  qtx11extras
+                  solid
+                  wayland
+                  xcb-util-keysyms))
     (home-page "https://invent.kde.org/plasma/kscreenlocker")
     (synopsis "Screen locking library")
     (description