summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-02-04 23:55:59 +0100
committerLeo Famulari <leo@famulari.name>2019-02-04 23:56:39 +0100
commit035542e93ae1bde8fbe1ca99acee77b8241d86fa (patch)
tree84a8a2a081313081b4317f1da9eac3376cfd139d /gnu/packages
parent6bf2201350e0ce64a52c1aee9d878783eeb098a7 (diff)
downloadguix-035542e93ae1bde8fbe1ca99acee77b8241d86fa.tar.gz
gnu: Remove unused patch 'xboing-CVE-2004-0149.patch'.
This is a followup to commit 740a335558a440245a2374fae9ffaa3427aa546c.

* gnu/packages/patches/xboing-CVE-2004-0149.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/xboing-CVE-2004-0149.patch134
1 files changed, 0 insertions, 134 deletions
diff --git a/gnu/packages/patches/xboing-CVE-2004-0149.patch b/gnu/packages/patches/xboing-CVE-2004-0149.patch
deleted file mode 100644
index b40146b434..0000000000
--- a/gnu/packages/patches/xboing-CVE-2004-0149.patch
+++ /dev/null
@@ -1,134 +0,0 @@
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0149
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=174924
----
- demo.c      |  2 +-
- editor.c    | 12 ++++++------
- file.c      |  2 +-
- highscore.c |  6 +++---
- misc.c      |  2 +-
- preview.c   |  2 +-
- 6 files changed, 13 insertions(+), 13 deletions(-)
-
-diff --git a/demo.c b/demo.c
-index 9084e70..f4fc2cd 100644
---- a/demo.c
-+++ b/demo.c
-@@ -154,7 +154,7 @@ static void DoBlocks(display, window)
- 
-     /* Construct the demo level filename */
-     if ((str = getenv("XBOING_LEVELS_DIR")) != NULL)
--        sprintf(levelPath, "%s/demo.data", str);
-+        snprintf(levelPath, sizeof(levelPath),"%s/demo.data", str);
-     else
-         sprintf(levelPath, "%s/demo.data", LEVEL_INSTALL_DIR);
- 
-diff --git a/editor.c b/editor.c
-index f2bb9ed..66d0679 100644
---- a/editor.c
-+++ b/editor.c
-@@ -213,7 +213,7 @@ static void DoLoadLevel(display, window)
- 
-     /* Construct the Edit level filename */
-     if ((str = getenv("XBOING_LEVELS_DIR")) != NULL)
--        sprintf(levelPath, "%s/editor.data", str);
-+        snprintf(levelPath,sizeof(levelPath)-1, "%s/editor.data", str);
-     else
-         sprintf(levelPath, "%s/editor.data", LEVEL_INSTALL_DIR);
- 
-@@ -958,8 +958,8 @@ static void LoadALevel(display)
-     if ((num > 0) && (num <= MAX_NUM_LEVELS))
-     {
- 	    /* Construct the Edit level filename */
--   	 	if ((str2 = getenv("XBOING_LEVELS_DIR")) != NULL)
--        	sprintf(levelPath, "%s/level%02ld.data", str2, (u_long) num);
-+        if ((str2 = getenv("XBOING_LEVELS_DIR")) != NULL)
-+            snprintf(levelPath, sizeof(levelPath)-1,"%s/level%02ld.data", str2, (u_long) num);
-     	else
-         	sprintf(levelPath, "%s/level%02ld.data", 
- 				LEVEL_INSTALL_DIR, (u_long) num);
-@@ -1017,9 +1017,9 @@ static void SaveALevel(display)
-     num = atoi(str);
-     if ((num > 0) && (num <= MAX_NUM_LEVELS))
-     {
--	    /* Construct the Edit level filename */
--   	 	if ((str2 = getenv("XBOING_LEVELS_DIR")) != NULL)
--        	sprintf(levelPath, "%s/level%02ld.data", str2, (u_long) num);
-+        /* Construct the Edit level filename */
-+        if ((str2 = getenv("XBOING_LEVELS_DIR")) != NULL)
-+            snprintf(levelPath, sizeof(levelPath)-1,"%s/level%02ld.data", str2, (u_long) num);
-     	else
-         	sprintf(levelPath, "%s/level%02ld.data", 
- 				LEVEL_INSTALL_DIR, (u_long) num);
-diff --git a/file.c b/file.c
-index 4c043cd..99a0854 100644
---- a/file.c
-+++ b/file.c
-@@ -139,7 +139,7 @@ void SetupStage(display, window)
- 
-     /* Construct the level filename */
-     if ((str = getenv("XBOING_LEVELS_DIR")) != NULL)
--        sprintf(levelPath, "%s/level%02ld.data", str, newLevel);
-+        snprintf(levelPath,sizeof(levelPath), "%s/level%02ld.data", str, newLevel);
-     else
-         sprintf(levelPath, "%s/level%02ld.data", LEVEL_INSTALL_DIR, newLevel);
- 
-diff --git a/highscore.c b/highscore.c
-index f0db3e9..792273e 100644
---- a/highscore.c
-+++ b/highscore.c
-@@ -1023,7 +1023,7 @@ int ReadHighScoreTable(type)
- 	{
- 		/* Use the environment variable if it exists */
- 		if ((str = getenv("XBOING_SCORE_FILE")) != NULL)
--			strcpy(filename, str);
-+            strncpy(filename, str, sizeof(filename)-1);
- 		else
- 			strcpy(filename, HIGH_SCORE_FILE);
- 	}
-@@ -1095,7 +1095,7 @@ int WriteHighScoreTable(type)
- 	{
- 		/* Use the environment variable if it exists */
- 		if ((str = getenv("XBOING_SCORE_FILE")) != NULL)
--			strcpy(filename, str);
-+            strncpy(filename, str, sizeof(filename)-1);
- 		else
- 			strcpy(filename, HIGH_SCORE_FILE);
- 	}	
-@@ -1218,7 +1218,7 @@ static int LockUnlock(cmd)
- 
- 	/* Use the environment variable if it exists */
- 	if ((str = getenv("XBOING_SCORE_FILE")) != NULL)
--		strcpy(filename, str);
-+        strncpy(filename, str, sizeof(filename)-1);
- 	else
- 		strcpy(filename, HIGH_SCORE_FILE);
- 
-diff --git a/misc.c b/misc.c
-index f3ab37e..7f3ddce 100644
---- a/misc.c
-+++ b/misc.c
-@@ -427,7 +427,7 @@ char *GetHomeDir()
-      */
- 
-     if ((ptr = getenv("HOME")) != NULL)
--        (void) strcpy(dest, ptr);
-+        (void) strncpy(dest, ptr,sizeof(dest)-1);
-     else
-     {
-         /* HOME variable is not present so get USER var */
-diff --git a/preview.c b/preview.c
-index 41c1187..687f566 100644
---- a/preview.c
-+++ b/preview.c
-@@ -139,7 +139,7 @@ static void DoLoadLevel(display, window)
- 
-     /* Construct the Preview level filename */
-     if ((str = getenv("XBOING_LEVELS_DIR")) != NULL)
--        sprintf(levelPath, "%s/level%02d.data", str, lnum);
-+        snprintf(levelPath, sizeof(levelPath)-1, "%s/level%02d.data", str, lnum);
-     else
-         sprintf(levelPath, "%s/level%02d.data", LEVEL_INSTALL_DIR, lnum);
- 
--- 
-2.15.1
-