summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-16 14:56:34 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-16 15:48:08 +0200
commit06a4a3634ad6a97423f178449dce206ec9bdcb49 (patch)
tree45d86e6929471dc2b98ee1c5b5957c636ed29208 /gnu/packages
parent6a3d23c77a436fd5432b4f8d6aef532e503e225e (diff)
downloadguix-06a4a3634ad6a97423f178449dce206ec9bdcb49.tar.gz
gnu: python-bash-kernel: Do not propagate 'python-ipykernel'.
Failing that, Guix-Jupyter sees both kernels in environments containing
python-bash-kernel and its ";;guix environment" command thus fails.

* gnu/packages/jupyter.scm (python-bash-kernel)[propagated-inputs]: Move
everything to...
[inputs]: ... here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/jupyter.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 5bcbd99c24..441e19bf47 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019, 2022 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
@@ -620,9 +620,10 @@ Docker registry.")
               (invoke "python" "-m" "bash_kernel.install" "--prefix" out)
               #t))))))
    (inputs
-     (list bash))
-   (propagated-inputs
-     (list python-pexpect python-ipykernel python-jupyter-client))
+     (list bash
+           python-pexpect
+           python-ipykernel
+           python-jupyter-client))
    (home-page "https://github.com/takluyver/bash_kernel")
    (synopsis "Jupyter kernel for Bash")
    (description "A bash shell kernel for Jupyter.")