summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-08-13 20:51:42 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-08-13 21:21:40 +0200
commit07fecda3ddf78847ca4a51d9d11d5b48553037b5 (patch)
tree5830993e189bbef83412f1b1c9824b6991258663 /gnu/packages
parent893299b3ee64d6055ff311f96b1bf792cbf83012 (diff)
downloadguix-07fecda3ddf78847ca4a51d9d11d5b48553037b5.tar.gz
gnu: ocaml-timed: Update to 1.1.
* gnu/packages/ocaml.scm (ocaml-timed): Update to 1.1.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 5 insertions, 16 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b34b73cf87..576e0525f3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4911,31 +4911,20 @@ is also support for writing OCaml syntax extensions in a camlp4 style.")
 (define-public ocaml-timed
   (package
     (name "ocaml-timed")
-    (version "1.0")
+    (version "1.1")
     (home-page "https://github.com/rlepigre/ocaml-timed")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url (string-append home-page ".git"))
-                    (commit (string-append name "_" version))))
+                    (commit version)))
               (sha256
                (base32
-                "0hfxz710faxy5yk97bkfnw87r732jcxxhmjppwrbfdb6pd0wks96"))
+                "1aqmkpjv5jk95lc2m3qyyrhw8ra7n9wj8pv3bfc83l737zv0hjn1"))
               (file-name (git-file-name name version))))
-    (build-system ocaml-build-system)
+    (build-system dune-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'build
-           (lambda _
-             (invoke "make")))
-         (replace 'install
-           (lambda _
-             (invoke "make" "install")))
-         (replace 'check
-           (lambda _
-             (invoke "make" "tests"))))))
+     '(#:test-target "."))
     (synopsis "Timed references for imperative state")
     (description "Timed references for imperative state.  This module provides
 an alternative type for references (or mutable cells) supporting undo/redo