summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 11:29:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:57 +0100
commit09e9ad334ac15ddea7e440cb1737f2c687f5c43a (patch)
treedf544e05fe3af46aad182c559a9c4b5324c81456 /gnu/packages
parent0b13a75716136aac6ffee5f1f10bec77393a1ca7 (diff)
downloadguix-09e9ad334ac15ddea7e440cb1737f2c687f5c43a.tar.gz
gnu: Add r-univoutl.
* gnu/packages/cran.scm (r-univoutl): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bebf4acbe4..855a3c956e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18349,3 +18349,29 @@ e.g. knapsack and subset sum procedures, derivative-free Nelder-Mead and
 Hooke-Jeeves minimization, and some (evolutionary) global optimization
 functions.")
     (license license:gpl3+)))
+
+(define-public r-univoutl
+  (package
+    (name "r-univoutl")
+    (version "0.1-5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "univOutl" version))
+       (sha256
+        (base32
+         "193wrpkvgmlrx43nag8w3ivrlqm37nm6g86wcvd3bgw3hchs70gi"))))
+    (properties `((upstream-name . "univOutl")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-hmisc" ,r-hmisc)
+       ("r-robustbase" ,r-robustbase)))
+    (home-page "https://github.com/marcellodo/univOutl")
+    (synopsis "Detection of univariate outliers")
+    (description
+     "This package provides well-known outlier detection techniques in the
+univariate case.  Methods to deal with skewed distribution are included too.
+The Hidiroglou-Berthelot (1986) method to search for outliers in ratios of
+historical data is implemented as well.  When available, survey weights can be
+used in outliers detection.")
+    (license license:gpl2+)))