summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-02-04 16:47:14 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2024-02-07 13:44:26 +0100
commit0a1d503b284bf304663fdbaa9dd465b339ef730d (patch)
treed380b8e7770e83995895521c0d9bd30bc98ac487 /gnu/packages
parenta042bfcd7eecb3499d42f143eff733b669f2bbe0 (diff)
downloadguix-0a1d503b284bf304663fdbaa9dd465b339ef730d.tar.gz
gnu: geos: Update to 3.12.1.
* gnu/packages/geo.scm (geos): Update to 3.12.1.
  [arguments]: Update 'patch-test-shebangs.

Change-Id: I4c5a7dd0ce0e95f813474ff4841a844e63451d24
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/geo.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 3171efa0dc..6135451c16 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -434,7 +434,7 @@ OpenStreetMap written in C using eXpat, Cairo and GLib.")
 (define-public geos
   (package
     (name "geos")
-    (version "3.11.2")
+    (version "3.12.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.osgeo.org/geos/geos-"
@@ -442,7 +442,7 @@ OpenStreetMap written in C using eXpat, Cairo and GLib.")
                                   ".tar.bz2"))
               (sha256
                (base32
-                "1k744nwfa5sj4amzsdjxgac83wh6xfb9xi7z5bka7ic1jik7gw5i"))))
+                "00qdk9a4048pzfj2rhzkfw3lvm642znf6kr4x29i3d94494pxsnn"))))
     (build-system cmake-build-system)
     (arguments `(#:phases
                  (modify-phases %standard-phases
@@ -450,7 +450,7 @@ OpenStreetMap written in C using eXpat, Cairo and GLib.")
                     'unpack 'patch-test-shebangs
                     (lambda _
                       (substitute* '("tests/xmltester/testrunner.sh"
-                                     "tests/geostest/testrunner.sh")
+                                     "tests/xmltester/safe_to_xml.sh")
                         (("/bin/sh") (which "sh"))))))))
     (inputs
      (list glib))