summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-15 16:20:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 12:32:30 -0400
commit0a77b869322274030c4c0e8315ddea802da44c92 (patch)
treed6644d3a96c24c6434cafb672455513dbcbe6d0c /gnu/packages
parent02708e27fc993a5069768bab968b11adef12fca1 (diff)
downloadguix-0a77b869322274030c4c0e8315ddea802da44c92.tar.gz
gnu: qtwebengine-5: Update to 5.15.10.
* gnu/packages/qt.scm (qtwebengine-5): Update to 5.15.10.
[source]: Update snippet to preserve the whole openh264 third party directory.

Series-to: 65280@debbugs.gnu.org
Cover-letter:
Refresh Qt 5 and 6 packages
This series refreshes our core Qt packages to their latest releases,
5.15.10 and 6.5.2.

It also adds some tooling for the Qt team in the form of two manifests to
select all the core Qt 5 packages or the other core packages, that builds on
top of the series posted at https://issues.guix.gnu.org/65230.

With this new tooling, it took less than two days to update our complete core
Qt packages collection, with the most time spent on qtwebengine (it has a
large allow-list of 3rd party libraries that needed to be tuned), as well as
investigating test failures in a few Qt 6.5.2 packages.
END
Series-version: 2
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 3684ecaeef..8a236291af 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2611,14 +2611,14 @@ using the Enchant spell-checking library.")
   (package
     (inherit qtsvg-5)
     (name "qtwebengine")
-    (version "5.15.8")
+    (version "5.15.10")
     (source
      (origin
        (method url-fetch)
        (uri (qt-url name version))
        (sha256
         (base32
-         "1qv15g5anhlfsdwnjxy21vc3zxxm8149vysi774l93iab6mxqmjg"))
+         "1rz6vbmr1aydmixayazmpsy7v2naq25l72q1gmvrhf9yf69584q8"))
        (modules '((ice-9 ftw)
                   (ice-9 match)
                   (srfi srfi-1)
@@ -2711,7 +2711,7 @@ using the Enchant spell-checking library.")
                      "third_party/nasm"
                      "third_party/node"
                      "third_party/one_euro_filter"
-                     "third_party/openh264/src/codec/api/svc"
+                     "third_party/openh264"
                      "third_party/opus"
                      "third_party/ots"
                      "third_party/pdfium"